summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2020-11-24 18:36:08 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2020-11-24 21:29:27 -0500
commit737b8fdb75a81e32233c156453d8ae785c5ceb72 (patch)
treed4a54514617d38d97b0688b8c33a793d485a0407 /media-sound/playerctl
parentprofiles/package.mask: unmask dev-vcs/gitstats (ported to python3) (diff)
downloadgentoo-737b8fdb75a81e32233c156453d8ae785c5ceb72.tar.gz
gentoo-737b8fdb75a81e32233c156453d8ae785c5ceb72.tar.bz2
gentoo-737b8fdb75a81e32233c156453d8ae785c5ceb72.zip
media-sound/playerctl: bump to 2.2.1
Closes: https://github.com/gentoo/gentoo/pull/15134 Closes: https://bugs.gentoo.org/724798 Closes: https://bugs.gentoo.org/736497 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'media-sound/playerctl')
-rw-r--r--media-sound/playerctl/Manifest1
-rw-r--r--media-sound/playerctl/playerctl-2.2.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/playerctl/Manifest b/media-sound/playerctl/Manifest
index ba75dcebacb9..c338741e2f63 100644
--- a/media-sound/playerctl/Manifest
+++ b/media-sound/playerctl/Manifest
@@ -1,2 +1,3 @@
DIST playerctl-2.0.1.tar.gz 43700 BLAKE2B 9df01bdb5f71a589a40462ed807b0f150d8c90921d1e0ef96bf99f20d9e58345307af35b39cc95e8ab37fcf9e5686935d856e050b61210188008b65281e63557 SHA512 6a5807abc79358bab0ad30a11897a8109121d5eb7d9e17d2c695221ef83942c3c7235fc738ab27c9dd2d3364c04737355e9c88ec5d49f999565565fb4494f720
DIST playerctl-2.0.2.tar.gz 44241 BLAKE2B 3a1d5f59fdb0067f1147f4ef95990ae0755a372469c0f03491b4f3aec8d0cf754bb4d3057063211ee810532967ace0d35fa6a7f3f8cee8d7a5c09031cb5b11c9 SHA512 ad588f81d42c8000ccd2d2dedacfcd82887a958189b354ad6285545f7ed59e885febe0c3f9e3da915ae0fd0af4bfb4cefda54f17f0560fc4c00b1be6e92f3ac0
+DIST playerctl-2.2.1.tar.gz 66255 BLAKE2B 76732d8074b17ca958b7efe08d7be8d4bce3ba1ec65346a219478b4807c600218e1b8fe971892e7df16ad49273721a5b423bced2bd3441e9f89497375d4e0d84 SHA512 9c08a3f1d5517d7f4270ed92f226453618fc9f0688688d1af9ff55f0c77efeb1b67daa4adc481546215491550f8528095d376ab099c8ddca05235bfb34b36eb7
diff --git a/media-sound/playerctl/playerctl-2.2.1.ebuild b/media-sound/playerctl/playerctl-2.2.1.ebuild
new file mode 100644
index 000000000000..1c7dfe34655f
--- /dev/null
+++ b/media-sound/playerctl/playerctl-2.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 xdg-utils meson
+
+DESCRIPTION="A CLI utility to control media players over MPRIS"
+HOMEPAGE="https://github.com/acrisci/playerctl"
+SRC_URI="https://github.com/acrisci/playerctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc introspection"
+RESTRICT="test" # Requires dbus-next python package that's not in the tree
+
+RDEPEND="
+ dev-libs/glib:2
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( dev-util/gtk-doc )
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddatadir=share
+ -Dbindir=bin
+ $(meson_use doc gtk-doc)
+ $(meson_use introspection)
+ )
+
+ xdg_environment_reset # 596166
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/$(get_libdir)/libplayerctl.a || die
+
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+
+ newbashcomp data/playerctl.bash "${PN}"
+}