summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-13 17:42:40 +0100
committerSam James <sam@gentoo.org>2022-06-13 17:42:40 +0100
commit469899e6998360e2b6490a6aaeb55d393727a91f (patch)
tree2354191a086d6a17c7603ee06833775d9a861b07 /media-sound/pms
parentapp-admin/metalog: Stabilize 20220214 x86, #851618 (diff)
downloadgentoo-469899e6998360e2b6490a6aaeb55d393727a91f.tar.gz
gentoo-469899e6998360e2b6490a6aaeb55d393727a91f.tar.bz2
gentoo-469899e6998360e2b6490a6aaeb55d393727a91f.zip
media-sound/pms: fix build with GCC 12
Closes: https://bugs.gentoo.org/851621 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/pms')
-rw-r--r--media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch11
-rw-r--r--media-sound/pms/pms-0.42_p20170508-r1.ebuild6
2 files changed, 16 insertions, 1 deletions
diff --git a/media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch b/media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch
new file mode 100644
index 000000000000..b0d586eff2c3
--- /dev/null
+++ b/media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/851621
+--- a/src/message.cpp
++++ b/src/message.cpp
+@@ -23,6 +23,7 @@
+
+
+ #include <cstdarg>
++#include <ctime>
+ #include <stdio.h>
+ #include "message.h"
+
diff --git a/media-sound/pms/pms-0.42_p20170508-r1.ebuild b/media-sound/pms/pms-0.42_p20170508-r1.ebuild
index 9f0546f7b158..750e97d2c674 100644
--- a/media-sound/pms/pms-0.42_p20170508-r1.ebuild
+++ b/media-sound/pms/pms-0.42_p20170508-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.42_p20170508-gcc12-time.patch
+)
+
src_configure() {
local mycmakeargs=(
-DENABLE_DOC=$(usex doc)