summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-17 12:11:10 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-17 12:11:10 +0200
commitf91f7821e45d9e09b1098528d9ca086c39b5f6a2 (patch)
tree17563b45ae47d7bf1e7f0cb37b1aa198d353465a /media-sound/poc/poc-0.4.1.ebuild
parentmedia-sound/picoxine: Port to EAPI 7 (diff)
downloadgentoo-f91f7821e45d9e09b1098528d9ca086c39b5f6a2.tar.gz
gentoo-f91f7821e45d9e09b1098528d9ca086c39b5f6a2.tar.bz2
gentoo-f91f7821e45d9e09b1098528d9ca086c39b5f6a2.zip
media-sound/poc: Port to EAPI 7
Bug: https://bugs.gentoo.org/697272 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/poc/poc-0.4.1.ebuild')
-rw-r--r--media-sound/poc/poc-0.4.1.ebuild38
1 files changed, 13 insertions, 25 deletions
diff --git a/media-sound/poc/poc-0.4.1.ebuild b/media-sound/poc/poc-0.4.1.ebuild
index f91c5fc7dd44..a187a005a8fe 100644
--- a/media-sound/poc/poc-0.4.1.ebuild
+++ b/media-sound/poc/poc-0.4.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="mp3 and ogg streamer (include mp3cue and mp3cut)"
HOMEPAGE="http://www.bl0rg.net/software/poc"
@@ -12,29 +12,17 @@ SRC_URI="http://www.bl0rg.net/software/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-RDEPEND=""
-DEPEND="sys-devel/flex
- sys-devel/bison"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/^CFLAGS/s:-O2::' \
- -e '/^PREFIX/s:/local::' \
- Makefile
- epatch "${FILESDIR}"/${P}-fec-pkt-prototype.patch
- epatch "${FILESDIR}"/${P}-file-perms.patch
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed."
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-fec-pkt-prototype.patch
+ "${FILESDIR}"/${P}-file-perms.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
-src_install() {
- dodir /usr/bin /usr/share/man/man1
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc README TODO
+src_configure() {
+ tc-export CC
}