summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 16:40:06 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 17:23:07 +0100
commit99ae53f09a108e94277b16a3912aa384d429883e (patch)
tree0c5b75c17fe3c983059d70fc121761bf43e02674 /media-sound/positron/positron-1.1-r1.ebuild
parentpackage.mask: Mask media-sound/jack for removal, #298850 (diff)
downloadgentoo-99ae53f09a108e94277b16a3912aa384d429883e.tar.gz
gentoo-99ae53f09a108e94277b16a3912aa384d429883e.tar.bz2
gentoo-99ae53f09a108e94277b16a3912aa384d429883e.zip
media-sound/positron: distutils-r1, EAPI=6
Diffstat (limited to 'media-sound/positron/positron-1.1-r1.ebuild')
-rw-r--r--media-sound/positron/positron-1.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/positron/positron-1.1-r1.ebuild b/media-sound/positron/positron-1.1-r1.ebuild
new file mode 100644
index 000000000000..fe307a9901cc
--- /dev/null
+++ b/media-sound/positron/positron-1.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronization manager for the Neuros Audio Computer"
+HOMEPAGE="http://www.xiph.org/positron"
+SRC_URI="http://www.xiph.org/positron/files/source/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="vorbis"
+
+DEPEND="vorbis? ( dev-python/pyvorbis[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ # install docs in /usr/share/doc/${PF}, bug #241290
+ sed -i -e "s:share/doc/positron:share/doc/${PF}:" setup.py
+ distutils-r1_python_prepare_all
+}