summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2016-12-12 18:23:19 +0100
committerDaniel Pielmeier <billie@gentoo.org>2016-12-12 18:23:19 +0100
commit3fac5fffe2a1534a4137ba973174f09d02242a00 (patch)
treeef266ce8d93befaacb15305454e54450af6d68d7 /media-sound/puddletag/puddletag-1.2.0.ebuild
parentnet-print/hplip-plugin: Remove old. (diff)
downloadgentoo-3fac5fffe2a1534a4137ba973174f09d02242a00.tar.gz
gentoo-3fac5fffe2a1534a4137ba973174f09d02242a00.tar.bz2
gentoo-3fac5fffe2a1534a4137ba973174f09d02242a00.zip
media-sound/puddletag: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-sound/puddletag/puddletag-1.2.0.ebuild')
-rw-r--r--media-sound/puddletag/puddletag-1.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/puddletag/puddletag-1.2.0.ebuild b/media-sound/puddletag/puddletag-1.2.0.ebuild
new file mode 100644
index 000000000000..f2663c64810c
--- /dev/null
+++ b/media-sound/puddletag/puddletag-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime
+
+DESCRIPTION="Audio tag editor"
+HOMEPAGE="http://docs.puddletag.net/"
+SRC_URI="https://github.com/keithgg/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acoustid cover musicbrainz quodlibet"
+
+DEPEND=""
+RDEPEND=">=dev-python/PyQt4-4.9.6-r2[${PYTHON_USEDEP},svg]
+ >=dev-python/pyparsing-1.5.1[${PYTHON_USEDEP}]
+ >=media-libs/mutagen-1.21[${PYTHON_USEDEP}]
+ >=dev-python/configobj-4.7.2-r1[${PYTHON_USEDEP}]
+ acoustid? ( >=media-libs/chromaprint-0.6 )
+ musicbrainz? ( >=dev-python/python-musicbrainz-0.7.4-r1[${PYTHON_USEDEP}] )
+ cover? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ quodlibet? ( >=media-sound/quodlibet-2.5[${PYTHON_USEDEP}] )
+ >=dev-python/sip-4.14.2-r1:0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.0.1[${PYTHON_USEDEP}]"
+
+DOCS=(changelog HACKING NEWS THANKS TODO)