summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-09-24 21:07:09 +0300
committerMart Raudsepp <leio@gentoo.org>2021-09-24 21:15:57 +0300
commit26646b27529e13f7beb0c78fac339e1d78bf07d4 (patch)
tree4f66e5dd34df5e1e70c4fb5220ae84c2d7d594d1 /media-sound/pulseaudio-daemon
parentmedia-libs/libpulse: Add split package for pulseaudio libraries (diff)
downloadgentoo-26646b27529e13f7beb0c78fac339e1d78bf07d4.tar.gz
gentoo-26646b27529e13f7beb0c78fac339e1d78bf07d4.tar.bz2
gentoo-26646b27529e13f7beb0c78fac339e1d78bf07d4.zip
media-sound/pulseaudio-daemon: Add split package for pulseaudio daemon
Bug: https://bugs.gentoo.org/536780 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-sound/pulseaudio-daemon')
-rw-r--r--media-sound/pulseaudio-daemon/Manifest1
-rw-r--r--media-sound/pulseaudio-daemon/files/15.0-daemon-only.patch277
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch25
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio.conf.d6
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio.init.d-580
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio.service10
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio.tmpfiles1
-rw-r--r--media-sound/pulseaudio-daemon/metadata.xml66
-rw-r--r--media-sound/pulseaudio-daemon/pulseaudio-daemon-15.0.ebuild320
9 files changed, 786 insertions, 0 deletions
diff --git a/media-sound/pulseaudio-daemon/Manifest b/media-sound/pulseaudio-daemon/Manifest
new file mode 100644
index 000000000000..308d59508744
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/Manifest
@@ -0,0 +1 @@
+DIST pulseaudio-15.0.tar.xz 1521760 BLAKE2B a6f7b74fdcfe7f2a993eafb9f465946915a24b6801d3077971b9377290d6c70b3f8640a800abd09d5901db96a20349f31b1beedd9da2249f69b591fb8392f489 SHA512 352ef20384c76c631c0faa73b08e2318902a433712e0c086a5ac7a0ae58873c8d4be8f35879bdec71a93b19ae8e2ba073cacac4d56215bcf58375a0cd9d88833
diff --git a/media-sound/pulseaudio-daemon/files/15.0-daemon-only.patch b/media-sound/pulseaudio-daemon/files/15.0-daemon-only.patch
new file mode 100644
index 000000000000..9b18310f9e24
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/15.0-daemon-only.patch
@@ -0,0 +1,277 @@
+From 5bcbd2ba656ac38ba500dc110cc13dbaa0d77853 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <mart@leio.tech>
+Date: Fri, 24 Sep 2021 15:19:05 +0300
+Subject: [PATCH] build-sys: meson: Allow building the daemon only
+
+---
+ meson.build | 23 ++++++++++++++++++++---
+ meson_options.txt | 3 +++
+ po/meson.build | 3 ---
+ shell-completion/bash/meson.build | 2 ++
+ src/daemon/meson.build | 4 ++--
+ src/meson.build | 11 +++++++++++
+ src/modules/gsettings/meson.build | 3 +--
+ src/tests/meson.build | 9 +++++++--
+ src/utils/meson.build | 10 ++++++----
+ 9 files changed, 52 insertions(+), 16 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 63ed62342..420cc6fac 100644
+--- a/meson.build
++++ b/meson.build
+@@ -53,6 +53,8 @@ libpulse_mainloop_glib_version = '@0@.@1@.@2@'.format(
+ libpulse_mainloop_glib_version_info[1],
+ )
+
++i18n = import('i18n')
++
+ # Paths
+
+ prefix = get_option('prefix')
+@@ -68,6 +70,7 @@ localedir = join_paths(prefix, get_option('localedir'))
+ localstatedir = join_paths(prefix, get_option('localstatedir'))
+ sysconfdir = join_paths(prefix, get_option('sysconfdir'))
+ privlibdir = join_paths(libdir, 'pulseaudio')
++po_dir = join_paths(meson.current_source_dir(), 'po')
+
+ if host_machine.system() == 'windows'
+ # Windows only supports loading libraries from the same dir as the executable
+@@ -796,20 +799,28 @@ check_dep = dependency('check', version : '>= 0.9.10', required : get_option('te
+ if get_option('doxygen')
+ subdir('doxygen')
+ endif
+-subdir('po')
++if not get_option('daemon-only')
++ subdir('po')
++endif
+ if get_option('man')
+ subdir('man')
+ endif
+ subdir('shell-completion/bash')
+-subdir('shell-completion/zsh')
++if not get_option('daemon-only')
++ subdir('shell-completion/zsh')
++endif
+ subdir('src')
+-subdir('vala')
++if not get_option('daemon-only')
++ subdir('vala')
++endif
+
+ # Now generate config.h from everything above
+ configure_file(output : 'config.h', configuration : cdata)
+
+ # pkg-config files
+
++if not get_option('daemon-only')
++
+ pc_cdata = configuration_data()
+
+ pc_cdata.set('prefix', prefix)
+@@ -842,8 +853,12 @@ foreach file : pc_files
+ install_dir : pkgconfigdir)
+ endforeach
+
++endif # !daemon-only
++
+ # CMake files
+
++if not get_option('daemon-only')
++
+ m4 = find_program('m4', required: true)
+
+ cmakedir = join_paths(libdir, 'cmake', 'PulseAudio')
+@@ -872,6 +887,8 @@ configure_file(
+ install_dir : cmakedir,
+ )
+
++endif # !daemon-only
++
+ ############################################################
+
+ # Final summary
+diff --git a/meson_options.txt b/meson_options.txt
+index bb41a42a7..62828ac5c 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,6 +1,9 @@
+ option('daemon',
+ type : 'boolean', value : true,
+ description : 'Enable building and installation of pulseaudio daemon and supporting configuration files')
++option('daemon-only',
++ type : 'boolean', value : false,
++ description : 'Build and install only the pulseaudio daemon and supporting configuration files, relying on a system installation of libpulse')
+ option('doxygen',
+ type : 'boolean', value : true,
+ description : 'Enable building and installation of documentation generated with doxygen')
+diff --git a/po/meson.build b/po/meson.build
+index 34278db47..33429373c 100644
+--- a/po/meson.build
++++ b/po/meson.build
+@@ -1,4 +1,3 @@
+-i18n = import('i18n')
+ i18n.gettext(
+ meson.project_name(),
+ preset: 'glib',
+@@ -7,5 +6,3 @@ i18n.gettext(
+ args: ['--msgid-bugs-address=https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/new',
+ '--width=90'],
+ )
+-
+-po_dir = meson.current_source_dir()
+diff --git a/shell-completion/bash/meson.build b/shell-completion/bash/meson.build
+index 3ba5cb16f..83d90b94b 100644
+--- a/shell-completion/bash/meson.build
++++ b/shell-completion/bash/meson.build
+@@ -8,6 +8,7 @@ if bashcompletiondir != 'no'
+ ]
+ endif
+
++ if not get_option('daemon-only')
+ aliases += [
+ 'pacat',
+ 'pactl',
+@@ -16,6 +17,7 @@ if bashcompletiondir != 'no'
+ 'parec',
+ 'parecord',
+ ]
++ endif
+
+ install_data('pulseaudio', install_dir : bashcompletiondir)
+
+diff --git a/src/daemon/meson.build b/src/daemon/meson.build
+index 262e193b2..e8f70a453 100644
+--- a/src/daemon/meson.build
++++ b/src/daemon/meson.build
+@@ -30,8 +30,8 @@ executable('pulseaudio',
+ install_rpath : privlibdir,
+ include_directories : [configinc, topinc],
+ link_args : ['-ffast-math'],
+- link_with : [libpulsecore, libpulsecommon, libpulse],
+- dependencies : [ltdl_dep, cap_dep, dbus_dep, libsystemd_dep, dl_dep, libintl_dep, platform_dep, platform_socket_dep],
++ link_with : [libpulsecore],
++ dependencies : [ltdl_dep, cap_dep, dbus_dep, libsystemd_dep, dl_dep, libintl_dep, platform_dep, platform_socket_dep, libpulsecommon_dep, libpulse_dep],
+ c_args : pa_c_args,
+ )
+
+diff --git a/src/meson.build b/src/meson.build
+index e2860811b..a56667271 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -188,6 +188,15 @@ else
+ endif
+ # FIXME: Do SIMD things
+
++if get_option('daemon-only')
++ libpulsecommon_dep = cc.find_library('pulsecommon-' + pa_version_major_minor, dirs : privlibdir, required : true)
++ libpulse_dep = dependency('libpulse', required : true)
++ libpulse_simple_dep = dependency('libpulse-simple', required : true)
++ if glib_dep.found()
++ libpulse_mainloop_glib_dep = dependency('libpulse-mainloop-glib', required : true)
++ endif
++else
++
+ libpulsecommon = shared_library('pulsecommon-' + pa_version_major_minor,
+ libpulsecommon_sources,
+ libpulsecommon_headers,
+@@ -207,6 +216,8 @@ libpulsecommon = shared_library('pulsecommon-' + pa_version_major_minor,
+ libpulsecommon_dep = declare_dependency(link_with: libpulsecommon)
+
+ subdir('pulse')
++endif
++
+ if get_option('daemon')
+ subdir('pulsecore')
+ subdir('daemon')
+diff --git a/src/modules/gsettings/meson.build b/src/modules/gsettings/meson.build
+index 68a72c3ff..9604699e7 100644
+--- a/src/modules/gsettings/meson.build
++++ b/src/modules/gsettings/meson.build
+@@ -8,8 +8,7 @@ gsettings_helper = executable('gsettings-helper',
+ gsettings_helper_sources,
+ c_args : pa_c_args,
+ include_directories : [configinc, topinc],
+- link_with : [libpulsecommon, libpulse],
+- dependencies : [gio_dep],
++ dependencies : [gio_dep, libpulsecommon_dep, libpulse_dep],
+ install_dir : pulselibexecdir,
+ install_rpath : privlibdir,
+ install : true,
+diff --git a/src/tests/meson.build b/src/tests/meson.build
+index acd301037..56d71299f 100644
+--- a/src/tests/meson.build
++++ b/src/tests/meson.build
+@@ -20,8 +20,6 @@ default_tests += [
+ [ check_dep, libpulse_dep, libpulsecommon_dep ] ],
+ [ 'json-test', 'json-test.c',
+ [ check_dep, libpulse_dep, libpulsecommon_dep ] ],
+- [ 'mainloop-test', 'mainloop-test.c',
+- [ check_dep, libpulse_dep, libpulsecommon_dep ] ],
+ [ 'proplist-test', 'proplist-test.c',
+ [ check_dep, libpulse_dep, libpulsecommon_dep ] ],
+ [ 'thread-mainloop-test', 'thread-mainloop-test.c',
+@@ -32,6 +30,13 @@ default_tests += [
+ [ check_dep, libm_dep, libpulse_dep, libpulsecommon_dep ] ],
+ ]
+
++if not get_option('daemon-only')
++ default_tests += [
++ [ 'mainloop-test', 'mainloop-test.c',
++ [ check_dep, libpulse_dep, libpulsecommon_dep ] ],
++ ]
++endif
++
+ if get_option('daemon')
+ default_tests += [
+ [ 'asyncmsgq-test', 'asyncmsgq-test.c',
+diff --git a/src/utils/meson.build b/src/utils/meson.build
+index c9635fdb6..7ed6e738f 100644
+--- a/src/utils/meson.build
++++ b/src/utils/meson.build
+@@ -1,3 +1,4 @@
++if not get_option('daemon-only')
+ pacat_sources = [
+ 'pacat.c',
+ ]
+@@ -41,6 +42,7 @@ executable('pactl',
+ dependencies : [sndfile_dep, libintl_dep],
+ c_args : pa_c_args,
+ )
++endif
+
+ if get_option('daemon')
+ if host_machine.system() != 'windows'
+@@ -53,8 +55,7 @@ if get_option('daemon')
+ install: true,
+ install_rpath : privlibdir,
+ include_directories : [configinc, topinc],
+- link_with : [libpulsecommon, libpulse],
+- dependencies: [libintl_dep],
++ dependencies: [libintl_dep, libpulsecommon_dep, libpulse_dep],
+ c_args : pa_c_args,
+ )
+
+@@ -67,13 +68,13 @@ if get_option('daemon')
+ install: true,
+ install_rpath : privlibdir,
+ include_directories : [configinc, topinc],
+- link_with : [libpulsecommon, libpulse],
+- dependencies: [libintl_dep],
++ dependencies: [libintl_dep, libpulsecommon_dep, libpulse_dep],
+ c_args : pa_c_args,
+ )
+ endif
+ endif
+
++if not get_option('daemon-only')
+ if x11_dep.found()
+ pax11publish_sources = [
+ 'pax11publish.c',
+@@ -121,3 +122,4 @@ if dbus_dep.found() and fftw_dep.found()
+ endif
+
+ install_data('pa-info', install_dir : bindir)
++endif
+--
+2.32.0
+
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch
new file mode 100644
index 000000000000..f3df62031d34
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/806052
+
+commit 42af3ee08381faa5807fde68d4c8ec0d7ad5e9a5
+Author: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
+Date: Tue Aug 3 09:43:32 2021 +0300
+
+ build-sys: meson: Require xice, xsm and xtst for daemon only
+
+ Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/613>
+
+--- a/meson.build
++++ b/meson.build
+@@ -681,9 +681,9 @@ endif
+ x11_dep = dependency('x11-xcb', required : get_option('x11'))
+ if x11_dep.found()
+ xcb_dep = dependency('xcb', required : true, version : '>= 1.6')
+- ice_dep = dependency('ice', required : true)
+- sm_dep = dependency('sm', required : true)
+- xtst_dep = dependency('xtst', required : true)
++ ice_dep = dependency('ice', required : get_option('daemon'))
++ sm_dep = dependency('sm', required : get_option('daemon'))
++ xtst_dep = dependency('xtst', required : get_option('daemon'))
+ cdata.set('HAVE_X11', 1)
+ if cc.has_function('XSetIOErrorExitHandler', dependencies: x11_dep)
+ cdata.set('HAVE_XSETIOERROREXITHANDLER', 1)
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio.conf.d b/media-sound/pulseaudio-daemon/files/pulseaudio.conf.d
new file mode 100644
index 000000000000..9e7245344a57
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio.conf.d
@@ -0,0 +1,6 @@
+# Config file for /etc/init.d/pulseaudio
+
+# For more see "pulseaudio -h".
+
+# Startup options
+PA_OPTS="--log-target=syslog --disallow-module-loading=1"
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio.init.d-5 b/media-sound/pulseaudio-daemon/files/pulseaudio.init.d-5
new file mode 100644
index 000000000000..a14f5e74aa53
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio.init.d-5
@@ -0,0 +1,80 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need localmount
+ use net
+
+ local script="/etc/pulse/system.pa"
+
+ for opt in ${PA_OPTS}; do
+ case "$opt" in
+ --file=*) script="${opt#*=}" ;;
+ -F*) script="${opt#-F}" ;;
+ esac
+ done
+
+ config "$script"
+
+ local needs="$(get_options need)"
+ if [ -n "${needs}" ]; then
+ need ${needs}
+ return
+ fi
+
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-console-kit' "$script"; then
+ needs="${needs} consolekit"
+ fi
+
+#ifdef UDEV
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-udev-detect' "$script"; then
+ needs="${needs} udev"
+ fi
+#endif
+
+#ifdef AVAHI
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-zeroconf-publish' "$script"; then
+ needs="${needs} avahi-daemon"
+ fi
+#endif
+
+#ifdef BLUETOOTH
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-bt-proximity' "$script"; then
+ needs="${needs} bluetooth"
+ fi
+#endif
+
+#ifdef ALSA
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-alsa-(sink|source)' "$script" ||
+ egrep -q '^[[:space:]]*load-module[[:space:]]+module-(udev-)?detect' "$script" ||
+ egrep -q '^[[:space:]]*add-autoload-source[[:space:]]+(input|output)[[:space:]]+module-alsa-(sink|source)' "$script"; then
+ needs="${needs} alsasound"
+ fi
+#endif
+
+ need "${needs}"
+ save_options need "${needs}"
+}
+
+start() {
+ if [ -z "${PULSEAUDIO_SHOULD_NOT_GO_SYSTEMWIDE}" ]; then
+ eerror "Please don't use system wide PulseAudio unless you read the"
+ eerror "documentation available at http://www.pulseaudio.org/wiki/WhatIsWrongWithSystemMode"
+ eerror ""
+ eerror "When you're done, please set the variable PULSEAUDIO_SHOULD_NOT_GO_SYSTEMWIDE in"
+ eerror "/etc/conf.d/pulseaudio . Please remember that upstream does not support this mode"
+ eerror "when used for standard desktop configurations."
+ return 1
+ fi
+ ebegin "Starting pulseaudio"
+ PA_ALL_OPTS="${PA_OPTS} --fail=1 --daemonize=1 --system"
+ start-stop-daemon --start --exec /usr/bin/pulseaudio -- ${PA_ALL_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pulseaudio"
+ start-stop-daemon --stop --quiet --exec /usr/bin/pulseaudio --pidfile /var/run/pulse/pid
+ eend $?
+}
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio.service b/media-sound/pulseaudio-daemon/files/pulseaudio.service
new file mode 100644
index 000000000000..c5f0d5799929
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=System wide PulseAudio instance
+After=syslog.target network.target alsasound.service
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/pulseaudio --system --log-target=syslog
+
+[Install]
+WantedBy=multi-user.target
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio.tmpfiles b/media-sound/pulseaudio-daemon/files/pulseaudio.tmpfiles
new file mode 100644
index 000000000000..88374e35574b
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio.tmpfiles
@@ -0,0 +1 @@
+d /var/run/pulse 0755 pulse audio -
diff --git a/media-sound/pulseaudio-daemon/metadata.xml b/media-sound/pulseaudio-daemon/metadata.xml
new file mode 100644
index 000000000000..9808d54c65cf
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/metadata.xml
@@ -0,0 +1,66 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="X">
+ Build the X11 publish module to export PulseAudio information
+ through X11 protocol for clients to make use. Don't enable this
+ flag if you want to use a system wide instance. If unsure, enable
+ this flag.
+ </flag>
+ <flag name="alsa-plugin">
+ Request installing <pkg>media-plugins/alsa-plugins</pkg> with
+ PulseAudio plugin enabled. This ensures that clients supporting
+ ALSA only will use PulseAudio.
+ </flag>
+ <flag name="elogind">Use <pkg>sys-auth/elogind</pkg> for giving each session a PA client</flag>
+ <flag name="oss">
+ Enable OSS sink/source (output/input). Deprecated, upstream does
+ not support this on systems where other sink/source systems are
+ available (i.e.: Linux). The padsp wrapper is now always build
+ if the system supports OSS at all.
+ </flag>
+ <flag name="glib">
+ Build the GSettings PA module.
+ </flag>
+ <flag name="system-wide">
+ Allow preparation and installation of the system-wide init
+ script for PulseAudio. Since this support is only supported for
+ embedded situations, do not enable without reading the upstream
+ instructions at
+ https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/ .
+ </flag>
+ <flag name="asyncns">Use libasyncns for asynchronous name resolution.</flag>
+ <flag name="equalizer">
+ Enable the equalizer module (requires <pkg>sci-libs/fftw</pkg>).
+ </flag>
+ <flag name="ssl">
+ Use <pkg>dev-libs/openssl</pkg> to provide support for RAOP
+ (AirPort) streaming.
+ </flag>
+ <flag name="gdbm">
+ Use <pkg>sys-libs/gdbm</pkg> to store PulseAudio
+ databases. Recommended for desktop usage. This flag causes the
+ whole package to be licensed under GPL-2 or later.
+ </flag>
+ <flag name="webrtc-aec">
+ Uses the webrtc.org AudioProcessing library for enhancing VoIP calls
+ greatly in applications that support it by performing acoustic echo
+ cancellation, analog gain control, noise suppression and other processing.
+ </flag>
+ <flag name="systemd">
+ Build with <pkg>sys-apps/systemd</pkg> support to replace standalone
+ ConsoleKit.
+ </flag>
+ <flag name="native-headset">
+ Build with native HSP backend for bluez 5.
+ </flag>
+ <flag name="ofono-headset">
+ Build with oFono HFP backend for bluez 5, requires <pkg>net-misc/ofono</pkg>.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/media-sound/pulseaudio-daemon/pulseaudio-daemon-15.0.ebuild b/media-sound/pulseaudio-daemon/pulseaudio-daemon-15.0.ebuild
new file mode 100644
index 000000000000..e0d3851c2149
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/pulseaudio-daemon-15.0.ebuild
@@ -0,0 +1,320 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV/_pre*}"
+MY_P="pulseaudio-${MY_PV}"
+
+inherit bash-completion-r1 gnome2-utils meson optfeature systemd tmpfiles udev
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/pulseaudio/pulseaudio"
+else
+ SRC_URI="https://freedesktop.org/software/pulseaudio/releases/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+# libpulse-simple and libpulse link to libpulse-core; this is daemon's
+# library and can link to gdbm and other GPL-only libraries. In this
+# cases, we have a fully GPL-2 package. Leaving the rest of the
+# GPL-forcing USE flags for those who use them.
+LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
+
+SLOT="0"
+
+# +alsa-plugin as discussed in bug #519530
+# TODO: Deal with bluez5-gstreamer - requires ldacenc and rtpldacpay gstreamer elements
+# TODO: Find out why webrtc-aec is + prefixed - there's already the always available speexdsp-aec
+# NOTE: The current ebuild sets +X almost certainly just for the pulseaudio.desktop file
+IUSE="+alsa +alsa-plugin +asyncns bluetooth dbus elogind equalizer +gdbm gstreamer +glib gtk ipv6 jack lirc
+native-headset ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev +webrtc-aec +X zeroconf"
+
+RESTRICT="!test? ( test )"
+
+# See "*** BLUEZ support not found (requires D-Bus)" in configure.ac
+# Basically all IUSE are either ${MULTILIB_USEDEP} for client libs or they belong under !daemon ()
+# We duplicate alsa-plugin, {native,ofono}-headset under daemon to let users deal with them at once
+REQUIRED_USE="
+ alsa-plugin? ( alsa )
+ bluetooth? ( dbus )
+ ?? ( elogind systemd )
+ equalizer? ( dbus )
+ native-headset? ( bluetooth )
+ ofono-headset? ( bluetooth )
+ udev? ( || ( alsa oss ) )
+ zeroconf? ( dbus )
+"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/XML-Parser
+ sys-devel/gettext
+ virtual/libiconv
+ virtual/libintl
+ virtual/pkgconfig
+ orc? ( >=dev-lang/orc-0.4.15 )
+ system-wide? ( dev-util/unifdef )
+"
+
+# NOTE:
+# - libpcre needed in some cases, bug #472228
+# - media-libs/speexdsp is providing echo canceller implementation and used in resampler
+# TODO: libatomic_ops is only needed on some architectures and conditions, and then at runtime too
+COMMON_DEPEND="
+ >=media-libs/libpulse-${PV}[glib?]
+ dev-libs/libatomic_ops
+ >=media-libs/libsndfile-1.0.20
+ >=media-libs/speexdsp-1.2
+ || (
+ elibc_glibc? ( virtual/libc )
+ elibc_uclibc? ( virtual/libc )
+ dev-libs/libpcre:3
+ )
+ alsa? ( >=media-libs/alsa-lib-1.0.24 )
+ asyncns? ( >=net-libs/libasyncns-0.1 )
+ bluetooth? (
+ >=net-wireless/bluez-5
+ media-libs/sbc
+ )
+ dev-libs/libltdl
+ sys-kernel/linux-headers
+ >=sys-libs/libcap-2.22-r2
+ dbus? ( >=sys-apps/dbus-1.4.12 )
+ elogind? ( sys-auth/elogind )
+ equalizer? (
+ sci-libs/fftw:3.0
+ )
+ gdbm? ( sys-libs/gdbm:= )
+ glib? ( >=dev-libs/glib-2.28.0:2 )
+ gstreamer? (
+ media-libs/gst-plugins-base
+ >=media-libs/gstreamer-1.14
+ )
+ gtk? ( x11-libs/gtk+:3 )
+ jack? ( virtual/jack )
+ lirc? ( app-misc/lirc )
+ ofono-headset? ( >=net-misc/ofono-1.13 )
+ orc? ( >=dev-lang/orc-0.4.15 )
+ selinux? ( sec-policy/selinux-pulseaudio )
+ sox? ( >=media-libs/soxr-0.1.1 )
+ ssl? ( dev-libs/openssl:= )
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+ udev? ( >=virtual/udev-143[hwdb(+)] )
+ webrtc-aec? ( >=media-libs/webrtc-audio-processing-0.2:0 )
+ X? (
+ >=x11-libs/libxcb-1.6
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libX11-1.4.0
+ >=x11-libs/libXtst-1.0.99.2
+ )
+ zeroconf? ( >=net-dns/avahi-0.6.12[dbus] )
+ !<media-sound/pulseaudio-15.0-r100
+"
+
+# pulseaudio ships a bundle xmltoman, which uses XML::Parser
+DEPEND="
+ ${COMMON_DEPEND}
+ test? ( >=dev-libs/check-0.9.10 )
+ X? ( x11-base/xorg-proto )
+"
+
+# alsa-utils dep is for the alsasound init.d script (see bug 155707); TODO: read it
+# NOTE: Only system-wide needs acct-group/audio unless elogind/systemd is not used
+RDEPEND="
+ ${COMMON_DEPEND}
+ system-wide? (
+ alsa? ( media-sound/alsa-utils )
+ acct-user/pulse
+ acct-group/audio
+ acct-group/pulse-access
+ )
+"
+
+# This is a PDEPEND to avoid a circular dep
+PDEPEND="
+ alsa? ( alsa-plugin? ( >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio] ) )
+"
+
+DOCS=( NEWS README )
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch
+ "${FILESDIR}"/${PV}-daemon-only.patch
+)
+
+src_prepare() {
+ default
+
+ gnome2_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ --localstatedir="${EPREFIX}"/var
+
+ -Ddaemon=true
+ -Ddaemon-only=true
+ -Ddoxygen=false
+ -Dgcov=false
+ -Dman=false
+ # tests involve random modules, so just do them for the native # TODO: tests should run always
+ $(meson_use test tests)
+ -Ddatabase=$(usex gdbm gdbm simple) # tdb is also an option but no one cares about it
+ -Dstream-restore-clear-old-devices=true
+ -Drunning-from-build-tree=false
+
+ # Paths
+ -Dmodlibexecdir="${EPREFIX}/usr/$(get_libdir)/pulseaudio/modules" # Was $(get_libdir)/${P}
+ -Dsystemduserunitdir=$(systemd_get_userunitdir)
+ -Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
+ -Dbashcompletiondir="$(get_bashcompdir)" # Alternatively DEPEND on app-shells/bash-completion for pkg-config to provide the value
+
+ # Optional features
+ $(meson_feature alsa)
+ $(meson_feature asyncns)
+ $(meson_feature zeroconf avahi)
+ $(meson_feature bluetooth bluez5)
+ -Dbluez5-gstreamer=disabled # no ldacenc/rtpldacpay gst elements packaged yet
+ $(meson_use native-headset bluez5-native-headset)
+ $(meson_use ofono-headset bluez5-ofono-headset)
+ $(meson_feature dbus)
+ $(meson_feature elogind)
+ $(meson_feature equalizer fftw)
+ $(meson_feature glib) # WARNING: toggling this likely changes ABI
+ $(meson_feature glib gsettings) # Supposedly correct?
+ $(meson_feature gstreamer)
+ $(meson_feature gtk)
+ -Dhal-compat=true # Consider disabling on next revbump
+ $(meson_use ipv6)
+ $(meson_feature jack)
+ $(meson_feature lirc)
+ $(meson_feature ssl openssl)
+ $(meson_feature orc)
+ $(meson_feature oss oss-output)
+ -Dsamplerate=disabled # Matches upstream
+ $(meson_feature sox soxr)
+ -Dspeex=enabled
+ $(meson_feature systemd)
+ $(meson_feature tcpd tcpwrap) # TODO: This should technically be enabled for 32bit too, but at runtime it probably is never used without daemon?
+ $(meson_feature udev)
+ -Dvalgrind=auto
+ $(meson_feature X x11)
+
+ # Echo cancellation
+ -Dadrian-aec=false # Not packaged?
+ $(meson_feature webrtc-aec)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Installed by media-libs/libpulse
+ rm "${ED}/$(get_bashcompdir)"/pulseaudio || die
+
+ if use system-wide; then
+ newconfd "${FILESDIR}"/pulseaudio.conf.d pulseaudio
+
+ use_define() {
+ local define=${2:-$(echo ${1} | tr '[:lower:]' '[:upper:]')}
+
+ use "${1}" && echo "-D${define}" || echo "-U${define}"
+ }
+
+ unifdef -x 1 \
+ $(use_define zeroconf AVAHI) \
+ $(use_define alsa) \
+ $(use_define bluetooth) \
+ $(use_define udev) \
+ "${FILESDIR}"/pulseaudio.init.d-5 \
+ > "${T}"/pulseaudio \
+ || die
+
+ doinitd "${T}"/pulseaudio
+
+ systemd_dounit "${FILESDIR}"/pulseaudio.service
+
+ # We need /var/run/pulse, bug 442852
+ newtmpfiles "${FILESDIR}"/pulseaudio.tmpfiles pulseaudio.conf
+ else
+ # Prevent warnings when system-wide is not used, bug 447694
+ if use dbus; then
+ rm "${ED}"/etc/dbus-1/system.d/pulseaudio-system.conf || die
+ fi
+ fi
+
+ if use zeroconf; then
+ sed -i \
+ -e '/module-zeroconf-publish/s:^#::' \
+ "${ED}/etc/pulse/default.pa" \
+ || die
+ fi
+
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+
+ if use system-wide; then
+ tmpfiles_process "pulseaudio.conf"
+
+ elog "You have enabled the 'system-wide' USE flag for pulseaudio."
+ elog "This mode should only be used on headless servers, embedded systems,"
+ elog "or thin clients. It will usually require manual configuration, and is"
+ elog "incompatible with many expected pulseaudio features."
+ elog "On normal desktop systems, system-wide mode is STRONGLY DISCOURAGED."
+ elog ""
+ elog "For more information, see"
+ elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/"
+ elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/SystemWide/"
+ elog " https://wiki.gentoo.org/wiki/PulseAudio#Headless_server"
+ elog ""
+ fi
+
+ if use equalizer; then
+ elog "You will need to load some extra modules to make qpaeq work."
+ elog "You can do that by adding the following two lines in"
+ elog "/etc/pulse/default.pa and restarting pulseaudio:"
+ elog "load-module module-equalizer-sink"
+ elog "load-module module-dbus-protocol"
+ elog ""
+ fi
+
+ if use native-headset && use ofono-headset; then
+ elog "You have enabled both native and ofono headset profiles. The runtime decision"
+ elog "which to use is done via the 'headset' argument of module-bluetooth-discover."
+ elog ""
+ fi
+
+ if use systemd; then
+ elog "It's recommended to start pulseaudio via its systemd user units:"
+ elog ""
+ elog " systemctl --user enable pulseaudio.service pulseaudio.socket"
+ elog ""
+ elog "The change from autospawn to user units will take effect after restarting."
+ elog ""
+ fi
+
+ optfeature_header "PulseAudio can be enhanced by installing the following:"
+ use equalizer && optfeature "using the qpaeq script" dev-python/PyQt5[dbus,widgets]
+ use dbus && optfeature "restricted realtime capabilities via D-Bus" sys-auth/rtkit
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}