summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-05-29 08:46:09 +0300
committerSam James <sam@gentoo.org>2022-05-29 07:45:01 +0100
commit34273e346cc4de995217339b25922efde21c1ffe (patch)
treec4f6fde6f944d0f18a6914a58f06d5226711c982 /media-sound/pulseaudio-daemon
parentmedia-libs/libpulse: Add IUSE valgrind (diff)
downloadgentoo-34273e346cc4de995217339b25922efde21c1ffe.tar.gz
gentoo-34273e346cc4de995217339b25922efde21c1ffe.tar.bz2
gentoo-34273e346cc4de995217339b25922efde21c1ffe.zip
media-sound/pulseaudio-daemon: Add local USE valgrind
Daemon code needs on pa_in_valgrind from libpulse. Add local USE valgrind and correct dependency requirement. Closes: https://bugs.gentoo.org/847541 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25669 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/pulseaudio-daemon')
-rw-r--r--media-sound/pulseaudio-daemon/metadata.xml1
-rw-r--r--media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0.ebuild7
2 files changed, 5 insertions, 3 deletions
diff --git a/media-sound/pulseaudio-daemon/metadata.xml b/media-sound/pulseaudio-daemon/metadata.xml
index 0a4437e23510..01b2fcbf1b72 100644
--- a/media-sound/pulseaudio-daemon/metadata.xml
+++ b/media-sound/pulseaudio-daemon/metadata.xml
@@ -56,6 +56,7 @@
Build with <pkg>sys-apps/systemd</pkg> support to replace standalone
ConsoleKit.
</flag>
+ <flag name="valgrind">Compile in valgrind memory hints</flag>
<flag name="native-headset">
Build with native HSP backend for bluez 5.
</flag>
diff --git a/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0.ebuild b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0.ebuild
index e1c72c7c113e..17d8424a2b3e 100644
--- a/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0.ebuild
+++ b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0.ebuild
@@ -33,7 +33,7 @@ SLOT="0"
# TODO: Find out why webrtc-aec is + prefixed - there's already the always available speexdsp-aec
# NOTE: The current ebuild sets +X almost certainly just for the pulseaudio.desktop file
IUSE="+alsa +alsa-plugin aptx +asyncns bluetooth dbus elogind equalizer +gdbm gstreamer +glib gtk ipv6 jack ldac lirc
-native-headset ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev +webrtc-aec +X zeroconf"
+native-headset ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev valgrind +webrtc-aec +X zeroconf"
RESTRICT="!test? ( test )"
@@ -56,7 +56,7 @@ REQUIRED_USE="
# - media-libs/speexdsp is providing echo canceller implementation and used in resampler
# TODO: libatomic_ops is only needed on some architectures and conditions, and then at runtime too
COMMON_DEPEND="
- >=media-libs/libpulse-${PV}[dbus?,glib?,systemd?,tcpd?,X?]
+ >=media-libs/libpulse-${PV}[dbus?,glib?,systemd?,tcpd?,valgrind?,X?]
dev-libs/libatomic_ops
>=media-libs/libsndfile-1.0.20
>=media-libs/speexdsp-1.2
@@ -95,6 +95,7 @@ COMMON_DEPEND="
systemd? ( sys-apps/systemd:= )
tcpd? ( sys-apps/tcp-wrappers )
udev? ( >=virtual/udev-143[hwdb(+)] )
+ valgrind? ( dev-util/valgrind )
webrtc-aec? ( >=media-libs/webrtc-audio-processing-0.2:0 )
X? (
>=x11-libs/libxcb-1.6
@@ -211,7 +212,7 @@ src_configure() {
$(meson_feature systemd)
$(meson_feature tcpd tcpwrap) # TODO: This should technically be enabled for 32bit too, but at runtime it probably is never used without daemon?
$(meson_feature udev)
- -Dvalgrind=auto
+ $(meson_feature valgrind)
$(meson_feature X x11)
# Echo cancellation