summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-09-24 21:08:30 +0300
committerMart Raudsepp <leio@gentoo.org>2021-09-24 21:15:57 +0300
commit9d6f88e10e942ae8e3a475e1e842ce1c423d70ec (patch)
treed35416212e68dbd182b109283c7fb79fde749dfe /media-sound/pulseaudio
parentmedia-sound/pulseaudio-daemon: Add split package for pulseaudio daemon (diff)
downloadgentoo-9d6f88e10e942ae8e3a475e1e842ce1c423d70ec.tar.gz
gentoo-9d6f88e10e942ae8e3a475e1e842ce1c423d70ec.tar.bz2
gentoo-9d6f88e10e942ae8e3a475e1e842ce1c423d70ec.zip
media-sound/pulseaudio: Add metapackage for pulseaudio split packages
Bug: https://bugs.gentoo.org/536780 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-sound/pulseaudio')
-rw-r--r--media-sound/pulseaudio/pulseaudio-15.0-r100.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/pulseaudio/pulseaudio-15.0-r100.ebuild b/media-sound/pulseaudio/pulseaudio-15.0-r100.ebuild
new file mode 100644
index 000000000000..bc04ffed9af7
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-15.0-r100.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
+SRC_URI=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="metapackage"
+
+SLOT="0"
+
+IUSE="+alsa +alsa-plugin bluetooth +daemon +glib jack zeroconf"
+
+# TODO: Get rid of the REQUIRED_USE by adapting the consumers to the splits with correct USE deps and dropping IUSE here
+REQUIRED_USE="
+ !daemon? (
+ !alsa
+ !alsa-plugin
+ !bluetooth
+ !jack
+ !zeroconf
+ )
+"
+
+RDEPEND="
+ >=media-libs/libpulse-${PV}[glib?,${MULTILIB_USEDEP}]
+ daemon? ( >=media-sound/pulseaudio-daemon-${PV}[alsa?,bluetooth?,jack?,zeroconf?] )
+"
+DEPEND="${RDEPEND}"
+# TODO: Figure out alsa-plugin handling, where pulseaudio-daemon isn't a multilib-minimal package
+PDEPEND="alsa? ( alsa-plugin? ( >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,${MULTILIB_USEDEP}] ) )"
+BDEPEND=""
+
+S="${WORKDIR}"