summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-11-01 13:04:22 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-11-01 13:04:35 +0100
commit81e0652d27f0d1a6e65336a7bbb3dfa2e283f602 (patch)
treec9394bd3704fd4f9a6c175195c6d299d122109eb /media-sound/qjackctl/qjackctl-9999.ebuild
parentdev-qt: Add Qt 5.13.2 (diff)
downloadgentoo-81e0652d27f0d1a6e65336a7bbb3dfa2e283f602.tar.gz
gentoo-81e0652d27f0d1a6e65336a7bbb3dfa2e283f602.tar.bz2
gentoo-81e0652d27f0d1a6e65336a7bbb3dfa2e283f602.zip
media-sound/qjackctl-{0.6.0,9999}: bump + added live ebuild
Closes: https://bugs.gentoo.org/628856 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/qjackctl/qjackctl-9999.ebuild')
-rw-r--r--media-sound/qjackctl/qjackctl-9999.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/qjackctl/qjackctl-9999.ebuild b/media-sound/qjackctl/qjackctl-9999.ebuild
new file mode 100644
index 000000000000..c9e9519c8454
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic qmake-utils autotools git-r3 xdg-utils
+
+DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+EGIT_REPO_URI="https://git.code.sf.net/p/qjackctl/code"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="alsa dbus debug portaudio"
+
+RDEPEND="
+ app-arch/gzip
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+src_prepare() {
+ eautoreconf
+
+ default
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable portaudio) \
+ --enable-jack-version
+
+ eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_compile() {
+ emake -f ${PN}.mak
+}
+
+src_install() {
+ default
+
+ gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz"
+ gunzip "${D}/usr/share/man/man1/qjackctl.1.gz"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}