summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/quodlibet/quodlibet-3.1.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/quodlibet/quodlibet-3.1.2.ebuild')
-rw-r--r--media-sound/quodlibet/quodlibet-3.1.2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/quodlibet/quodlibet-3.1.2.ebuild b/media-sound/quodlibet/quodlibet-3.1.2.ebuild
new file mode 100644
index 000000000000..1e344b165e1b
--- /dev/null
+++ b/media-sound/quodlibet/quodlibet-3.1.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 gnome2-utils fdo-mime
+
+DESCRIPTION="audio library tagger, manager, and player for GTK+"
+HOMEPAGE="http://code.google.com/p/quodlibet/"
+SRC_URI="http://bitbucket.org/lazka/${PN}-files/raw/default/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="+dbus gstreamer ipod +udev"
+
+RDEPEND="dev-libs/keybinder:3[introspection]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=media-libs/mutagen-1.22[${PYTHON_USEDEP}]
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ )
+ !gstreamer? ( media-libs/xine-lib )
+ dbus? (
+ app-misc/media-player-info
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ )
+ ipod? ( media-libs/libgpod[python,${PYTHON_USEDEP}] )
+ udev? ( virtual/udev )"
+DEPEND="dev-util/intltool"
+REQUIRED_USE="ipod? ( dbus )"
+
+src_prepare() {
+ sed -i -e '/usr.*bin.*env/s:python:python2:' {exfalso,quodlibet}.py || die
+
+ local qlconfig=${PN}/config.py
+
+ if ! use gstreamer; then
+ sed -i -e '/backend/s:gstbe:xinebe:' ${qlconfig} || die
+ fi
+
+ sed -i -e '/gst_pipeline/s:"":"alsasink":' ${qlconfig} || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}