summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/rosegarden/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/rosegarden/files')
-rw-r--r--media-sound/rosegarden/files/rosegarden-12.12.25-debug.patch18
-rw-r--r--media-sound/rosegarden/files/rosegarden-13.10-segfault_at_export_to_lilypond.patch28
2 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/rosegarden/files/rosegarden-12.12.25-debug.patch b/media-sound/rosegarden/files/rosegarden-12.12.25-debug.patch
new file mode 100644
index 000000000000..d52b4c6b1928
--- /dev/null
+++ b/media-sound/rosegarden/files/rosegarden-12.12.25-debug.patch
@@ -0,0 +1,18 @@
+--- rosegarden-12.12.25/configure.ac
++++ rosegarden-12.12.25/configure.ac
+@@ -137,9 +137,12 @@
+ CXXFLAGS_BUILD="$CXXFLAGS_RELEASE"
+ RG_DEFINES_BUILD="$RG_DEFINES_RELEASE"
+
+-AC_ARG_ENABLE(debug, [AS_HELP_STRING([--enable-debug],[enable debug support [default=no]])],[AC_MSG_NOTICE([enabling debug build])
+-CXXFLAGS_BUILD="$CXXFLAGS_DEBUG"
+-RG_DEFINES_BUILD="$RG_DEFINES_DEBUG"])
++AC_ARG_ENABLE([debug], AS_HELP_STRING([--enable-debug],[enable debug support [default=no]]))
++
++AS_IF([test "x$enable_debug" = "xyes"], [
++ AC_MSG_NOTICE([enabling debug build])
++ CXXFLAGS_BUILD="$CXXFLAGS_DEBUG" RG_DEFINES_BUILD="$RG_DEFINES_DEBUG"
++])
+
+ if test x"$USER_CXXFLAGS" != x; then
+ AC_MSG_NOTICE([The CXXFLAGS environment variable is set to "$USER_CXXFLAGS".])
diff --git a/media-sound/rosegarden/files/rosegarden-13.10-segfault_at_export_to_lilypond.patch b/media-sound/rosegarden/files/rosegarden-13.10-segfault_at_export_to_lilypond.patch
new file mode 100644
index 000000000000..5efa65258aa7
--- /dev/null
+++ b/media-sound/rosegarden/files/rosegarden-13.10-segfault_at_export_to_lilypond.patch
@@ -0,0 +1,28 @@
+Index: src/document/io/LilyPondExporter.cpp
+===================================================================
+--- src/document/io/LilyPondExporter.cpp (revision 13602)
++++ src/document/io/LilyPondExporter.cpp (revision 13603)
+@@ -706,13 +706,18 @@
+ std::string header = protectIllegalChars(metadata.get<String>(property));
+ if (property == headerCopyright) {
+ // replace a (c) or (C) with a real Copyright symbol
+- int posCpy = header.find("c");
+- if (!posCpy) posCpy = header.find("C");
+- if (posCpy) {
+- std::string leftOfCpy = header.substr(0, posCpy - 1);
+- std::string rightOfCpy = header.substr(posCpy + 2);
++ size_t posCpy = header.find("(c)");
++ if (posCpy == std::string::npos) posCpy = header.find("(C)");
++ if (posCpy != std::string::npos) {
++ std::string leftOfCpy = header.substr(0, posCpy);
++ std::string rightOfCpy = header.substr(posCpy + 3);
+ str << indent(col) << property << " = \\markup { \"" << leftOfCpy << "\""
+ << "\\char ##x00A9" << "\"" << rightOfCpy << "\" }" << std::endl;
++ } else {
++ if (header != "") {
++ str << indent(col) << property << " = \""
++ << header << "\"" << std::endl;
++ }
+ }
+ } else if (header != "") {
+ str << indent(col) << property << " = \"" << header << "\"" << std::endl;