summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-08 18:53:33 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-08 18:53:33 +0200
commit52aa359238d71ff37942157fd9abedc8ba2bb6d6 (patch)
tree39a95aaa0c39b762d43f1db62799dd2b77792c88 /media-sound/sexypsf/sexypsf-0.4.8.ebuild
parentmedia-sound/toolame: Fix building under -fno-common (diff)
downloadgentoo-52aa359238d71ff37942157fd9abedc8ba2bb6d6.tar.gz
gentoo-52aa359238d71ff37942157fd9abedc8ba2bb6d6.tar.bz2
gentoo-52aa359238d71ff37942157fd9abedc8ba2bb6d6.zip
media-sound/sexypsf: Fix building under -fno-common
Closes: https://bugs.gentoo.org/706820 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/sexypsf/sexypsf-0.4.8.ebuild')
-rw-r--r--media-sound/sexypsf/sexypsf-0.4.8.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/media-sound/sexypsf/sexypsf-0.4.8.ebuild b/media-sound/sexypsf/sexypsf-0.4.8.ebuild
index 427a0518e2ca..7f7bf7f7e776 100644
--- a/media-sound/sexypsf/sexypsf-0.4.8.ebuild
+++ b/media-sound/sexypsf/sexypsf-0.4.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,19 +11,25 @@ SRC_URI="http://projects.raphnet.net/sexypsf/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND="sys-libs/zlib"
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
-src_compile() {
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.8-Makefile.patch
+ "${FILESDIR}"/${PN}-0.4.8-fno-common.patch
+)
+
+src_configure() {
tc-export CC
- cd Linux || die
- emake
+}
+
+src_compile() {
+ emake -C Linux
}
src_install() {
dobin Linux/sexypsf
- dodoc Docs/*
+ dodoc -r Docs/.
}