summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-12 17:03:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-12 17:03:00 +0100
commitae26101d26ecbf4d8fcb789f88828bbaa423789c (patch)
tree5c1eb7470d3e55dd0b1b32cd03a56fc76f9deb9f /media-sound/shnflacverify
parentmedia-sound/gmpc: Port to EAPI 7 (diff)
downloadgentoo-ae26101d26ecbf4d8fcb789f88828bbaa423789c.tar.gz
gentoo-ae26101d26ecbf4d8fcb789f88828bbaa423789c.tar.bz2
gentoo-ae26101d26ecbf4d8fcb789f88828bbaa423789c.zip
media-sound/shnflacverify: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/shnflacverify')
-rw-r--r--media-sound/shnflacverify/shnflacverify-0.3.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/media-sound/shnflacverify/shnflacverify-0.3.ebuild b/media-sound/shnflacverify/shnflacverify-0.3.ebuild
index 80e08a78f3bb..7f5b5eb1bf00 100644
--- a/media-sound/shnflacverify/shnflacverify-0.3.ebuild
+++ b/media-sound/shnflacverify/shnflacverify-0.3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit eutils
@@ -12,12 +12,10 @@ SRC_URI="http://downloads.sourceforge.net/project/${PN}/${PN}/${P}/${P}.zip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-lang/perl
+RDEPEND="
app-arch/unzip
+ dev-lang/perl
media-libs/flac
media-sound/shntool
sys-apps/coreutils"
@@ -25,11 +23,14 @@ RDEPEND="${DEPEND}
S="${WORKDIR}"
src_prepare() {
- local X
+ default
+
edos2unix *.txt
+
+ local X
for X in flac md5sum shntool metaflac; do
einfo "setting \$${X}_cmd to $(type -p ${X})"
- sed -i -e "s|^\(\$${X}_cmd\s*=\s*'\)[^']*\('.*\)|\1$(type -p ${X})\2|g" shnflac*
+ sed -i -e "s|^\(\$${X}_cmd\s*=\s*'\)[^']*\('.*\)|\1$(type -p ${X})\2|g" shnflac* || die
done
}