summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-02 04:42:45 +0000
committerSam James <sam@gentoo.org>2021-12-02 04:43:14 +0000
commite73573692da466a260372f147612c7602bd8bf4b (patch)
tree8d765b95d46bc8f084331ad3caad1598734716a4 /media-sound/sidplayfp
parentmedia-sound/ttaenc: fix build on musl (diff)
downloadgentoo-e73573692da466a260372f147612c7602bd8bf4b.tar.gz
gentoo-e73573692da466a260372f147612c7602bd8bf4b.tar.bz2
gentoo-e73573692da466a260372f147612c7602bd8bf4b.zip
media-sound/sidplayfp: add musl patch
Closes: https://bugs.gentoo.org/764113 Thanks-to: ernsteiswuerfel <erhard_f@mailbox.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/sidplayfp')
-rw-r--r--media-sound/sidplayfp/files/sidplayfp-1.4.4-musl-limits.patch11
-rw-r--r--media-sound/sidplayfp/sidplayfp-1.4.4.ebuild9
2 files changed, 19 insertions, 1 deletions
diff --git a/media-sound/sidplayfp/files/sidplayfp-1.4.4-musl-limits.patch b/media-sound/sidplayfp/files/sidplayfp-1.4.4-musl-limits.patch
new file mode 100644
index 000000000000..ad810d66f5b5
--- /dev/null
+++ b/media-sound/sidplayfp/files/sidplayfp-1.4.4-musl-limits.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/764113
+--- a/src/IniConfig.cpp
++++ b/src/IniConfig.cpp
+@@ -36,6 +36,7 @@
+ # include <sys/types.h>
+ # include <sys/stat.h> /* mkdir */
+ # include <dirent.h> /* opendir */
++# include <limits.h>
+ #else
+ # include <windows.h>
+ #endif
diff --git a/media-sound/sidplayfp/sidplayfp-1.4.4.ebuild b/media-sound/sidplayfp/sidplayfp-1.4.4.ebuild
index 40dc1277bbd0..caff4726ef0c 100644
--- a/media-sound/sidplayfp/sidplayfp-1.4.4.ebuild
+++ b/media-sound/sidplayfp/sidplayfp-1.4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,11 +22,17 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.4-musl-limits.patch
+)
+
src_prepare() {
default
+
if ! use alsa; then
sed -i -e 's:alsa >= 1.0:dIsAbLe&:' configure || die
fi
+
if ! use pulseaudio; then
sed -i -e 's:libpulse-simple >= 1.0:dIsAbLe&:' configure || die
fi
@@ -34,5 +40,6 @@ src_prepare() {
src_configure() {
export ac_cv_header_linux_soundcard_h=$(usex oss)
+
econf
}