summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-09 14:08:50 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-09 14:09:03 +0200
commit797e0935c6550fd7a344f3187418f8666156d5d1 (patch)
treeb2a790013994838915a2b7536be8e93aaed7f84f /media-sound/sndpeek/sndpeek-1.41-r1.ebuild
parentapp-benchmarks/stress-ng: drop old version (diff)
downloadgentoo-797e0935c6550fd7a344f3187418f8666156d5d1.tar.gz
gentoo-797e0935c6550fd7a344f3187418f8666156d5d1.tar.bz2
gentoo-797e0935c6550fd7a344f3187418f8666156d5d1.zip
media-sound/sndpeek: respecting CFLAGS + removed unused patches
Closes: https://bugs.gentoo.org/736493 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/sndpeek/sndpeek-1.41-r1.ebuild')
-rw-r--r--media-sound/sndpeek/sndpeek-1.41-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/sndpeek/sndpeek-1.41-r1.ebuild b/media-sound/sndpeek/sndpeek-1.41-r1.ebuild
new file mode 100644
index 000000000000..ce8567bae371
--- /dev/null
+++ b/media-sound/sndpeek/sndpeek-1.41-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils toolchain-funcs
+
+DESCRIPTION="real-time audio visualization"
+HOMEPAGE="http://soundlab.cs.princeton.edu/software/sndpeek/"
+SRC_URI="http://soundlab.cs.princeton.edu/software/${PN}/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack oss"
+
+RDEPEND="
+ app-eselect/eselect-sndpeek
+ media-libs/freeglut
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ media-libs/libsndfile
+ jack? ( virtual/jack )
+ alsa? ( media-libs/alsa-lib )
+"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="|| ( alsa jack oss )"
+
+DOCS=( AUTHORS README THANKS TODO VERSIONS )
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+# "${FILESDIR}/${PN}-1.4-gcc.patch"
+)
+
+compile_backend() {
+ backend=$1
+ cd "${S}/src/sndpeek"
+ einfo "Compiling against ${backend}"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) \
+ CXX=$(tc-getCXX)
+ mv sndpeek{,-${backend}}
+ emake -f "makefile.${backend}" clean
+ cd -
+}
+
+src_compile() {
+ use alsa && compile_backend alsa
+ use jack && compile_backend jack
+ use oss && compile_backend oss
+}
+
+src_install() {
+ use alsa && dobin src/sndpeek/sndpeek-alsa
+ use jack && dobin src/sndpeek/sndpeek-jack
+ use oss && dobin src/sndpeek/sndpeek-oss
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Sndpeek now can use many audio engines, so you can specify audio engine"
+ elog "with sndpeek-{jack,alsa,oss}"
+ elog "Or you can use 'eselect sndpeek' to set the audio engine"
+
+ einfo "Calling eselect sndpeek update..."
+ eselect sndpeek update --if-unset
+}