summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott Furry <scott.wl.furry@gmail.com>2022-05-31 04:59:09 +0100
committerSam James <sam@gentoo.org>2022-05-31 05:06:59 +0100
commit976952fe40b45059bba077f0964df99baf44f9f6 (patch)
tree4beb4e5bbb809433c5b883b70fd10bef6bfcb6bb /media-sound/soundconverter/soundconverter-4.0.3.ebuild
parentnet-p2p/ncdc: add 1.23 (diff)
downloadgentoo-976952fe40b45059bba077f0964df99baf44f9f6.tar.gz
gentoo-976952fe40b45059bba077f0964df99baf44f9f6.tar.bz2
gentoo-976952fe40b45059bba077f0964df99baf44f9f6.zip
media-sound/soundconverter: add 4.0.3
Closes: https://bugs.gentoo.org/758197 Closes: https://bugs.gentoo.org/846092 Signed-off-by: Scott Furry <scott.wl.furry@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/soundconverter/soundconverter-4.0.3.ebuild')
-rw-r--r--media-sound/soundconverter/soundconverter-4.0.3.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-sound/soundconverter/soundconverter-4.0.3.ebuild b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
new file mode 100644
index 000000000000..9840037dc60f
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+inherit distutils-r1 xdg
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="https://soundconverter.org/"
+SRC_URI="https://github.com/kassoulet/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="aac flac mp3 ogg opus vorbis"
+
+# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
+# List in soundconverter/gstreamer.py
+# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
+RDEPEND="
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ ')
+ media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
+ media-plugins/gst-plugins-meta:1.0
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ media-libs/gst-plugins-good:1.0
+ mp3? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ )
+ aac? ( media-plugins/gst-plugins-faac:1.0 )
+ opus? ( media-plugins/gst-plugins-opus:1.0 )
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ ')
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ rm -v "${S}/CHANGELOG.old"
+ # workaround incorrect behavior when LINGUAS is set to an empty string
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
+ ! [[ -v LINGUAS && -z ${LINGUAS} ]] || rm po/*.po || die
+}
+
+python_install_all() {
+ rm -v "${D}/usr/share/glib-2.0/schemas/gschemas.compiled"
+ mv -v "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${P}"
+ distutils-r1_python_install_all
+}