summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-21 10:36:10 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-21 10:37:06 +0100
commit7af16ec37cff9558ae38d2b0b59378a85fb271ab (patch)
treebb3c1a1a24d9b093a312dcaa3eff02ec684a8717 /media-sound/soundconverter
parentmedia-sound/soundconverter: Drop old (diff)
downloadgentoo-7af16ec37cff9558ae38d2b0b59378a85fb271ab.tar.gz
gentoo-7af16ec37cff9558ae38d2b0b59378a85fb271ab.tar.bz2
gentoo-7af16ec37cff9558ae38d2b0b59378a85fb271ab.zip
media-sound/soundconverter: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-sound/soundconverter')
-rw-r--r--media-sound/soundconverter/Manifest1
-rw-r--r--media-sound/soundconverter/soundconverter-2.1.6.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-sound/soundconverter/Manifest b/media-sound/soundconverter/Manifest
index e6c0c748ff05..e2d7a6d1552d 100644
--- a/media-sound/soundconverter/Manifest
+++ b/media-sound/soundconverter/Manifest
@@ -1 +1,2 @@
DIST soundconverter-2.1.5.tar.xz 195380 SHA256 cace2109b967744325e4ce8938d286b78b86f0615d4f145966f42decc7a74e06 SHA512 6d42bd2cfa200e7af8c69ce94580a4f96bdb0354623207e5d1c3beadee89920363b5b8cee4cdcfa6fcbd036860d50f739b05e34e9a34608fe3d6243876936c6a WHIRLPOOL e3f9ea4bbe012aa8b977321ee85601c69d67324b35654b494ffe6792af8043a21af7d7d429929cea28fe7273e08e11f93da9b00cb4f99c88f22266e6b0c3419d
+DIST soundconverter-2.1.6.tar.xz 195864 SHA256 2ffb6718d8e43a67be4d99e5a9c7b5cd82fce15d30b4861608b7d1666884a690 SHA512 d607d4c260f0b8d810f7251f9bbcd02359984dd2a8bf3340be14602e3392362b9a6bc54a9f0c20f16bfee2f971f784a4093f535307dfb2d6087fb4492511a9ba WHIRLPOOL cfabdedc4cda2ec36537ec95443d0735905c13c369a6916842959a831fcceb322f3a2dfc47d3be0897b3a982cc10797dd89145a51550e9e4ef0d809c01b246ef
diff --git a/media-sound/soundconverter/soundconverter-2.1.6.ebuild b/media-sound/soundconverter/soundconverter-2.1.6.ebuild
new file mode 100644
index 000000000000..29534f12676b
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-2.1.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG=no
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2 multilib python-single-r1
+
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="http://soundconverter.org/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="aac flac mp3 opus vorbis"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/gconf-python[${PYTHON_USEDEP}]
+ dev-python/gnome-vfs-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
+ dev-python/libgnome-python[${PYTHON_USEDEP}]
+ gnome-base/libglade[${PYTHON_USEDEP}]
+ aac? (
+ media-plugins/gst-plugins-faac:0.10
+ media-plugins/gst-plugins-faad:0.10 )
+ flac? ( media-plugins/gst-plugins-flac:0.10 )
+ mp3? (
+ media-plugins/gst-plugins-lame:0.10
+ media-plugins/gst-plugins-mad:0.10
+ media-plugins/gst-plugins-taglib:0.10 )
+ vorbis? (
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-vorbis:0.10 )
+ opus? ( media-plugins/gst-plugins-opus:0.10 )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ python_fix_shebang .
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize "${ED%/}"/usr/$(get_libdir)/soundconverter/python
+}