summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-16 20:03:58 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-16 20:03:58 +0200
commit8828233cfe93238bc49eda2f83a9d9ea2da7b592 (patch)
treeb4eb6a73dabc1b84be32f12ab415f491aa65d3f0 /media-sound/spotify-tray
parentdev-python/spyder: drop version 5.1.4 (diff)
downloadgentoo-8828233cfe93238bc49eda2f83a9d9ea2da7b592.tar.gz
gentoo-8828233cfe93238bc49eda2f83a9d9ea2da7b592.tar.bz2
gentoo-8828233cfe93238bc49eda2f83a9d9ea2da7b592.zip
media-sound/spotify-tray: add version 1.3.2
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-sound/spotify-tray')
-rw-r--r--media-sound/spotify-tray/Manifest1
-rw-r--r--media-sound/spotify-tray/spotify-tray-1.3.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/media-sound/spotify-tray/Manifest b/media-sound/spotify-tray/Manifest
index 3bfe4a05e03f..334c376f03cf 100644
--- a/media-sound/spotify-tray/Manifest
+++ b/media-sound/spotify-tray/Manifest
@@ -1 +1,2 @@
DIST spotify-tray-1.3.1.tar.gz 22084 BLAKE2B ee8f269d1ac618794eee8a67b814f689f3a65f18433a1e3c2382465a2b9b247e70e16fb43f061d1c7cef9188f116d0c7e8478fe3ffe2ab5f2de54dc8ccb40808 SHA512 c1fd533e3879f2d9e451264969bc797c6b8ca35f191460d40822728fc6b637ec7487154b0794871f25cbd6e01b16c7ff5eb33806a1235ac09e45e49580d1337a
+DIST spotify-tray-1.3.2.tar.gz 22298 BLAKE2B da1399db3d42d969d983b9bae695ff55dbdff47ef49ac79e10e2681df45489505028901a0946dd70495a6a74b9eef979f9ef07a722a08cb93a2ba6749c106f4a SHA512 74ae5ebaa61497a0274646dad04d408bb4176bbbacbb0e80211bec9218d09e293c8abf4c9424de8123ba4440d63adb58c5b68ca53690d2e348d52efbbc3f88c1
diff --git a/media-sound/spotify-tray/spotify-tray-1.3.2.ebuild b/media-sound/spotify-tray/spotify-tray-1.3.2.ebuild
new file mode 100644
index 000000000000..28d534d9a35d
--- /dev/null
+++ b/media-sound/spotify-tray/spotify-tray-1.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="Wrapper around the Spotify client that adds a tray icon"
+HOMEPAGE="https://github.com/tsmetana/spotify-tray"
+SRC_URI="https://github.com/tsmetana/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}
+ media-sound/spotify
+"
+
+src_prepare() {
+ default
+ # Fix the name of the icon
+ sed -i -e 's/Icon=spotify/Icon=spotify-client/g' spotify-tray.desktop.in || die
+ eautoreconf
+}