summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-09-22 17:33:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-09-22 17:34:53 -0500
commit0f93a55798973a090c1d0207a172f4cc9f8de04d (patch)
tree9fab6c07764c49d7cbbc5d0b90b07564a4b61a44 /media-sound/spotify
parentdev-libs/pocl: initial import (diff)
downloadgentoo-0f93a55798973a090c1d0207a172f4cc9f8de04d.tar.gz
gentoo-0f93a55798973a090c1d0207a172f4cc9f8de04d.tar.bz2
gentoo-0f93a55798973a090c1d0207a172f4cc9f8de04d.zip
media-sound/spotify: 1.1.68 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/Manifest1
-rw-r--r--media-sound/spotify/spotify-1.1.68.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index f71b14a23300..1d417b26db98 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,3 @@
DIST spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb 95135550 BLAKE2B ad4587dd6b3c64a0398e0790203a7826e290a27542fa39ebbd6c7198d8ad1fd3fb06e8b030b64e1e61e0624ef20aafda08189266486cd073cb779ebff62ef502 SHA512 51d60f7592e5f31ea4b7e67736a85271cb48d4108459630da61c4ab67d2a470038240c1d6ff577280cb4498cf44f14d7bc7e0312f63d34265bcd1e70cd13142f
DIST spotify-client_1.1.67.586.gbb5ef64e_amd64.deb 118938508 BLAKE2B 41239d0c67e3f9e1e4ef2b437320307f1cf947e022635b7c3b9103bfe5fe33f0b1465e9384e78cbb4684b0dec2efd974aa2ac4d1a15860907d66be0b04b14246 SHA512 d105eed1f013be2704ad7f0aaeb80ab2f8f19a0cfe69782f32fc95241d2900560996ec17101222365e1ad3b02ff9fa866da3f0709277a5bb40d032f5a58f7062
+DIST spotify-client_1.1.68.632.g2b11de83_amd64.deb 112586002 BLAKE2B 9591b9ff4bc5ba4227cb964b4d77f80441701353d704c2ba502c8f8cf21b64ad406b89e41355c0b2db7a9dfa7db985b555603b38b6e8eed4371732f4b81e67d6 SHA512 742bf459d7d87cc269a4c29cd2489753c6f7b62f3ee2150808c4931c29ee0d89f5b5ae47589112768e5958da73cba857074845fd017bd53c4574ea84c6770074
diff --git a/media-sound/spotify/spotify-1.1.68.ebuild b/media-sound/spotify/spotify-1.1.68.ebuild
new file mode 100644
index 000000000000..86a2a079c2e7
--- /dev/null
+++ b/media-sound/spotify/spotify-1.1.68.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop pax-utils unpacker xdg
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/download/linux/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
+BUILD_ID_AMD64="632.g2b11de83"
+SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="libnotify local-playback pax-kernel pulseaudio systray"
+RESTRICT="mirror strip"
+
+BDEPEND=">=dev-util/patchelf-0.10"
+RDEPEND="
+ dev-libs/nss
+ dev-python/dbus-python
+ libnotify? ( x11-libs/libnotify )
+ dev-libs/openssl:0=
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/harfbuzz
+ media-libs/mesa[X(+)]
+ net-misc/curl[ssl]
+ net-print/cups[ssl]
+ pulseaudio? ( media-sound/pulseaudio )
+ !pulseaudio? ( media-sound/apulse )
+ local-playback? ( media-video/ffmpeg:0/56.58.58 )
+ systray? ( gnome-extra/gnome-integration-spotify )
+ x11-libs/gtk+:3
+ app-accessibility/at-spi2-atk
+ x11-libs/libxkbcommon
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/libSM
+ x11-libs/libICE
+"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="
+ opt/spotify/spotify-client/spotify
+ opt/spotify/spotify-client/libEGL.so
+ opt/spotify/spotify-client/libGLESv2.so
+ opt/spotify/spotify-client/libcef.so
+ opt/spotify/spotify-client/swiftshader/libEGL.so
+ opt/spotify/spotify-client/swiftshader/libGLESv2.so
+"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for systray integration
+ if use systray ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+
+ # Spotify links against libcurl-gnutls.so.4, which does not exist in Gentoo.
+ patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 usr/bin/spotify \
+ || die "failed to patch libcurl library dependency"
+}
+
+src_install() {
+ gunzip usr/share/doc/spotify-client/changelog.gz || die
+ dodoc usr/share/doc/spotify-client/changelog
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ LD_LIBRARY_PATH="/usr/$(get_libdir)/apulse" \\
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax-kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax-kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+}