summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Chantziaras <realnc@gmail.com>2018-09-13 21:34:53 +0300
committerMatthew Thode <prometheanfire@gentoo.org>2018-09-13 14:49:47 -0500
commita1ce4c7ca48772a6c3903109561bf0c4aa0e2eaa (patch)
treec173b37aaaaf9e2b24bb55b015d29ecc27061f2b /media-sound/spotify
parentdev-python/mysql-python: drop virtual/mysql dependency (diff)
downloadgentoo-a1ce4c7ca48772a6c3903109561bf0c4aa0e2eaa.tar.gz
gentoo-a1ce4c7ca48772a6c3903109561bf0c4aa0e2eaa.tar.bz2
gentoo-a1ce4c7ca48772a6c3903109561bf0c4aa0e2eaa.zip
media-sound/spotify: version bump to 1.0.89
Closes: https://bugs.gentoo.org/666188 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/Manifest1
-rw-r--r--media-sound/spotify/spotify-1.0.89.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 32b9aa2bec06..cddcaff79e0a 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,3 +1,4 @@
DIST spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb 95135550 BLAKE2B ad4587dd6b3c64a0398e0790203a7826e290a27542fa39ebbd6c7198d8ad1fd3fb06e8b030b64e1e61e0624ef20aafda08189266486cd073cb779ebff62ef502 SHA512 51d60f7592e5f31ea4b7e67736a85271cb48d4108459630da61c4ab67d2a470038240c1d6ff577280cb4498cf44f14d7bc7e0312f63d34265bcd1e70cd13142f
DIST spotify-client_1.0.80.480.g51b03ac3-13_amd64.deb 97542898 BLAKE2B a89f3f607c9fb03327886fc1b6eb8d433b32913aa7ff32e95f626a8ef7710c4d6102721b76e9a83f1342d1ac6f6941d85376b4cb878cf641f42f3c3756582eb9 SHA512 a46b1d28e6c40dbe9a86a38794186f2cdf31341fff953eaa5a5fdbb37c27c00ffe14a918b2552df0996d2842f009e6700bf8683e0667fc671dfd5b343251f20e
DIST spotify-client_1.0.88.353.g15c26ea1-14_amd64.deb 103367590 BLAKE2B 90de37c58643cd864b35e26f2d97507872adfa3a6d9b7832d46d0caf9d3383673c67b2e4d7d7015075912cc2ae3754f575f968bd6b743760d7a910d90581d25c SHA512 30592c34a2b1b9d546c753d03a8ead7459d83bd5f420e1dab92a1f2ff40ac2daa0f4f447b95cd499a30328aea1afe8949e05fdd0668b9caf637abdecf5e45742
+DIST spotify-client_1.0.89.313.g34a58dea-5_amd64.deb 103077554 BLAKE2B 21377d7836cc25bdba325ded3bbaefcd1cf5fb3525c541bbd846dc4cf021f680a50789a8c88b5ad8cfa7ea90a1bbccfa0c6fada5709eb7d4ea4dd5bc04df3c8d SHA512 ff7e8b5bc9889fe8b1a81eba789a84edb75cbfec9cd09eb1a55a56e16e9bd762342ecdf2960667521b12deab2b971e700fa971c89ff8aaae40657aeda01a43a8
diff --git a/media-sound/spotify/spotify-1.0.89.ebuild b/media-sound/spotify/spotify-1.0.89.ebuild
new file mode 100644
index 000000000000..412043be197f
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.89.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils pax-utils unpacker xdg-utils
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
+BUILD_ID_AMD64="313.g34a58dea-5"
+#BUILD_ID_X86=""
+#SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb )
+# x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_X86}_i386.deb )"
+SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify systray pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=">=dev-util/patchelf-0.9_p20180129"
+# zenity needed for filepicker
+RDEPEND="
+ dev-libs/openssl:0
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl[ssl]
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ libnotify? ( x11-libs/libnotify )
+ pulseaudio? ( media-sound/pulseaudio )
+ systray? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for systray integration
+ if use systray ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+
+ # Spotify links against libcurl-gnutls.so.4, which does not exist in Gentoo.
+ patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 usr/bin/spotify \
+ || die "failed to patch libcurl library dependency"
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}