summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-12-19 05:43:31 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-12-19 05:44:44 -0600
commite2a85fce4daf233e4c8ec97b5b89a98c9912cb0f (patch)
tree85c0e3074633b411747c43693b1fba16831cb6bc /media-sound/spotify
parentdev-lang/swig: amd64 stable wrt bug #589580 (diff)
downloadgentoo-e2a85fce4daf233e4c8ec97b5b89a98c9912cb0f.tar.gz
gentoo-e2a85fce4daf233e4c8ec97b5b89a98c9912cb0f.tar.bz2
gentoo-e2a85fce4daf233e4c8ec97b5b89a98c9912cb0f.zip
media-sound/spotify: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.45.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 20fea5d72186..dc79febc8c2e 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.43.123.g80176796-25_i386.deb 74352490 SHA256 3647c6a109203f7ce9ed3dbe99a9732ef5f6044adb277985f87ffde0e8183885 SHA512 a98d38e17895dcef06decc32dae45bf59ca21c6980f306ce21f325ca3371ccd9392f4c99d3d5dd57cd085b504b2e81954aa94d3f0cac4a744b0a725a160b4698 WHIRLPOOL 53dda2acabb6ab7f3f534261bcd365310f1773a6ccf00c8f9a6a84716bbc4819cb6d725962588a494003837a7ee99cba0407fcf4b31b3a39d1cb16c2a361bdcd
DIST spotify-client_1.0.43.125.g376063c5-91_amd64.deb 73159678 SHA256 7b68ede2428634b2fa1cca0bb13a73821b3a803774aa89f07b1af96622767ee2 SHA512 612ec8e06d0197460656315c314d1e1f4a1da4ab591c186288c5fc383d2902e20f9f8e0f4b1f9513e462a12a7fe98eb78ade90f650841556574164e3ad386f6e WHIRLPOOL abb4e7b90cd077e1c0ab13aa94d7cc068aadd5cfe397875121ec2e83a243898cfa880553d31b832264113cbf6defb86e63c8977ccb509ff5d870431e55ff0a0f
+DIST spotify-client_1.0.45.182.gbbd5909f-21_i386.deb 73429858 SHA256 54dda72db35a1771c95ff05e8b8ffeae13f826632737fd26caea55e8905cfa0c SHA512 4f75c6f044d5d8c2f0a11d86c5475ec4fda2d09eb5f37594c220e5c2dafa4db9ccd6da35ade1a690ee7496d888fa630822225378ab8725c8b110f990a6d5804a WHIRLPOOL 2603f55913dd27fdc7bf9e39ddb0963da11b8388b3d27289beec2e7576dff24b3037a6c6682dda436f5b690d5903f2dbabd6587c4d8d17dc0596a0b7d3943abb
+DIST spotify-client_1.0.45.182.gbbd5909f-72_amd64.deb 72229688 SHA256 dadf68c2cf1d09479632312301fb0ef9b18da841449141bacfa5e75d14e5fc6e SHA512 f266b22f2921d1a3f2ff4e71a6fd9b81f590c302b22f398bfc399ae97e6cb18442804b2bf663df9a4cf07116cd9007a014a086382811eb20568c3ebaf4e0e91a WHIRLPOOL a94cb705cd4b3b30823e8ffdc9dd758db3142bbadfba5dd21e4a3a2e03de7aaa1ab006a3ccf1c954fdd7f242c70e57e6c061043bd50dd5fd0e0f857a6b4f7de7
diff --git a/media-sound/spotify/spotify-1.0.45.ebuild b/media-sound/spotify/spotify-1.0.45.ebuild
new file mode 100644
index 000000000000..fbda1857bbc5
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.45.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+BUILD_ID="182.gbbd5909f"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-72_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-21_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl[ssl,curl_ssl_openssl]
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}