summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-09-18 23:30:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-09-18 23:30:45 -0500
commite66f7cd330db08ef20d01986fef86ac50f512701 (patch)
treeda8c564ef90fd74ea78399fcd19237a81deb0bcb /media-sound/spotify
parentwww-client/vivaldi: Version bump. (diff)
downloadgentoo-e66f7cd330db08ef20d01986fef86ac50f512701.tar.gz
gentoo-e66f7cd330db08ef20d01986fef86ac50f512701.tar.bz2
gentoo-e66f7cd330db08ef20d01986fef86ac50f512701.zip
media-sound/spotify: adding new alpha/beta for bug 550396
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.14.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index da8a402ac0c1..b8837786b447 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1 +1,3 @@
DIST spotify-client_0.9.17.1.g9b85d43.7-1_amd64.deb 42733568 SHA256 717a878bcfa495852d19ac34bb4b0fa1b2f063ab94547defd32725d1dec10775 SHA512 a19403558c0a641b0264641501c9538f169b9e64d532e5d54dd67b7edbb27d400f07395014c9693fed298a1331c053cc9e62988d1293e9b1f1809d68a74646ad WHIRLPOOL 712ac07a3cd3230e3de17e9209380d0e0cc9a33c77cb4753e04490c5bb9a4e2d3e386ee92ffadecd9888ea701aa2a0c4c1b8c579cfa2f5b61d72981a5736f495
+DIST spotify-client_1.0.14.122.gf29d9be0_i386.deb 69292192 SHA256 a83243d333919cab99b1b215ef144c4bb9be8f9f662a7111cefb384439338c5e SHA512 04233a23632ba2d44526c99e6eaa2b56f2227f1fb8628d1d61e74966e0e0aa291f8b6d7307514086126ca3f0e52d7c65ee2e3e0834b87e39df0e6114b474efde WHIRLPOOL e1f234c541699962598d0efe15b7f07e9281e303dc228c122cf563ec13d11aeb11f680f6deeb9e445b494018e7dcd079c4677abed637b7cf29b6f0360447585d
+DIST spotify-client_1.0.14.124.g4dfabc51_amd64.deb 65887386 SHA256 6fed225815ada3a290dd588c7f19a5c83df2712cd016d8e6ad0a2bba4ef66257 SHA512 e7781aeb8c828d6cf4d27adbc717dc0d2d216a55a8c1501152780eb22b6a4aecb7631ce3c3657c79a1ec6f8a213fe5d442fbe9548c1cabce632600b863956c7b WHIRLPOOL 0e34476c73ee4655c5fca892a0a8dbdc711fbb518e7ce7a8c1d9000e02b7295fd0923f9f3b5a29b829bddb9081d2a9d1bd566ad37c9bfc82de3b61c41198d2ba
diff --git a/media-sound/spotify/spotify-1.0.14.ebuild b/media-sound/spotify/spotify-1.0.14.ebuild
new file mode 100644
index 000000000000..efc35b891ea1
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.14.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+MY_PV_AMD64="${PV}.124.g4dfabc51"
+MY_PV_I386="${PV}.122.gf29d9be0"
+MY_P="${PN}-client_"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${MY_P}${MY_PV_AMD64}_amd64.deb )
+ x86? ( ${SRC_BASE}${MY_P}${MY_PV_I386}_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-libs/glib:2
+ || ( dev-libs/libgcrypt:11/11 dev-libs/libgcrypt:0/11 dev-libs/libgcrypt:0/20 )
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ net-misc/curl
+ sys-apps/util-linux
+ virtual/udev
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXtst
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.21 )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ #TODO: the semicolons will be fixed in 1.0.15, remove it then
+ sed -i \
+ -e 's/x-scheme-handler\/spotify$/x-scheme-handler\/spotify\;/g' \
+ -e 's/AudioVideo$/AudioVideo\;/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.Debian.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}