summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-29 23:38:25 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-29 23:38:25 +0200
commit0e526edd40d4b78c9797b593ba442d029da01a70 (patch)
tree5772a70370b1fd7b6f84e0130126a99dd14085c2 /media-sound/tagtool
parentmedia-sound/spotify: reformat metadata.xml (diff)
downloadgentoo-0e526edd40d4b78c9797b593ba442d029da01a70.tar.gz
gentoo-0e526edd40d4b78c9797b593ba442d029da01a70.tar.bz2
gentoo-0e526edd40d4b78c9797b593ba442d029da01a70.zip
media-sound/tagtool: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/631236 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/tagtool')
-rw-r--r--media-sound/tagtool/files/tagtool-0.12.3-QA-desktop.patch10
-rw-r--r--media-sound/tagtool/files/tagtool-0.12.3-autotools.patch (renamed from media-sound/tagtool/files/tagtool-0.12.3-underlinking.patch)24
-rw-r--r--media-sound/tagtool/tagtool-0.12.3-r2.ebuild (renamed from media-sound/tagtool/tagtool-0.12.3-r1.ebuild)24
3 files changed, 37 insertions, 21 deletions
diff --git a/media-sound/tagtool/files/tagtool-0.12.3-QA-desktop.patch b/media-sound/tagtool/files/tagtool-0.12.3-QA-desktop.patch
new file mode 100644
index 000000000000..50c290d0ee15
--- /dev/null
+++ b/media-sound/tagtool/files/tagtool-0.12.3-QA-desktop.patch
@@ -0,0 +1,10 @@
+--- a/data/tagtool.desktop.in
++++ b/data/tagtool.desktop.in
+@@ -3,6 +3,6 @@
+ _Comment=MP3 and Ogg Vorbis tag editor
+ Exec=tagtool
+ Icon=TagTool
+-Terminal=False
++Terminal=false
+ Type=Application
+ Categories=Audio;AudioVideo;AudioVideoEditing;
diff --git a/media-sound/tagtool/files/tagtool-0.12.3-underlinking.patch b/media-sound/tagtool/files/tagtool-0.12.3-autotools.patch
index 9569ad2fbaf5..40d1f5e80441 100644
--- a/media-sound/tagtool/files/tagtool-0.12.3-underlinking.patch
+++ b/media-sound/tagtool/files/tagtool-0.12.3-autotools.patch
@@ -1,10 +1,11 @@
-Fix underlinking issues caused by missing libm and libogg linking
-Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=513012
+* Fix underlinking issues caused by missing libm and libogg linking
+ https://bugs.gentoo.org/513012
+* Fix spurious test failure caused by incomplete POTFILES.in
+ https://bugs.gentoo.org/631236
+* In addition, fix nonidiomatic AC_ARG_ENABLE option handling.
-In addition, fix nonidiomatic AC_ARG_ENABLE option handling.
-
---- tagtool-0.12.3/configure.ac
-+++ tagtool-0.12.3/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -13,20 +13,16 @@
@@ -57,8 +58,15 @@ In addition, fix nonidiomatic AC_ARG_ENABLE option handling.
AM_CONDITIONAL(ENABLE_MP3, test "$enable_mp3" = "yes")
AM_CONDITIONAL(ENABLE_VORBIS, test "$enable_vorbis" = "yes")
---- tagtool-0.12.3/src/Makefile.am
-+++ tagtool-0.12.3/src/Makefile.am
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -22,3 +22,4 @@
+ src/vorbis_edit.c
+ src/vorbis_edit_field.c
+ src/vorbis_file.c
++src/vcedit.c
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -28,7 +28,8 @@
vorbis_sources = vorbis_file.c vorbis_file.h vorbis_edit.c \
vorbis_edit.h vorbis_edit_field.c vorbis_edit_field.h vcedit.c \
diff --git a/media-sound/tagtool/tagtool-0.12.3-r1.ebuild b/media-sound/tagtool/tagtool-0.12.3-r2.ebuild
index be7039a613eb..bdd326c02eb6 100644
--- a/media-sound/tagtool/tagtool-0.12.3-r1.ebuild
+++ b/media-sound/tagtool/tagtool-0.12.3-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -15,21 +15,20 @@ KEYWORDS="amd64 ppc ~sparc x86"
IUSE="mp3 +vorbis"
REQUIRED_USE="|| ( mp3 vorbis )"
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ x11-libs/gtk+:2
>=gnome-base/libglade-2.6
mp3? ( >=media-libs/id3lib-3.8.3-r6 )
vorbis? ( >=media-libs/libvorbis-1 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-QA-desktop.patch
)
src_prepare() {
- # QA fix for wrong boolean value
- sed -i -e 's/Terminal=False/Terminal=false/' data/tagtool.desktop.in || die
-
default
eautoreconf
}
@@ -43,9 +42,8 @@ src_configure() {
src_install() {
emake \
DESTDIR="${D}" \
- GNOME_SYSCONFDIR="${D}/etc" \
- sysdir="${D}/usr/share/applets/Multimedia" \
+ GNOME_SYSCONFDIR="${ED}"/etc \
+ sysdir="${ED}"/usr/share/applets/Multimedia \
install
-
- dodoc ChangeLog NEWS README TODO THANKS
+ einstalldocs
}