summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-17 21:24:42 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-17 21:24:58 +0100
commitc27e2e0ec5681ca6db2b11c91bf06d69294e972e (patch)
treeecf67878293441e9397db7668083ae97c9d218d6 /media-sound/timemachine
parentdev-tcltk/tkdnd: version bump to 2.9.2 (diff)
downloadgentoo-c27e2e0ec5681ca6db2b11c91bf06d69294e972e.tar.gz
gentoo-c27e2e0ec5681ca6db2b11c91bf06d69294e972e.tar.bz2
gentoo-c27e2e0ec5681ca6db2b11c91bf06d69294e972e.zip
media-sound/timemachine: 0.3.4 bump
1) switched to virtual/jack 2) organized deps 3) added desktop file Closes: https://bugs.gentoo.org/426672 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/timemachine')
-rw-r--r--media-sound/timemachine/Manifest1
-rw-r--r--media-sound/timemachine/files/timemachine-0.3.4-underlinking.patch24
-rw-r--r--media-sound/timemachine/timemachine-0.3.4.ebuild52
3 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/timemachine/Manifest b/media-sound/timemachine/Manifest
index cc0bf9a442e2..098061379454 100644
--- a/media-sound/timemachine/Manifest
+++ b/media-sound/timemachine/Manifest
@@ -1 +1,2 @@
DIST timemachine-0.3.3.tar.gz 169021 BLAKE2B db94419dff0b3778e71296c9bc855714a0cc14e2d0c56d00eec53c7337ba6883aacb107d5da4310937b6bf520b65efd3874f652710020a30dcd25e828d399eaf SHA512 9fd079d3be2a22ebd7a8afe6eebef9d2adab743c8d3c0124adcbaed78fb1863c5a087e95763185745f1d2767a939583814d0c889147c29742c39ab860c96748f
+DIST timemachine-0.3.4.tar.gz 91171 BLAKE2B 047106d22f7659a223f8d2cad9dbf9c224850951e19336866dd312840c67a09b5326202b832aa29f859b5c8cbc8f644750772ad32d4d1785dd6aa61890611a18 SHA512 1469f91290ab10232b469b8320cb80cdc9e6c47e922251ab4439ecb0e10a1b18066eccb221269e966a11477d3cf0d4acafca3f5aa3db574d3d1d6385235abba3
diff --git a/media-sound/timemachine/files/timemachine-0.3.4-underlinking.patch b/media-sound/timemachine/files/timemachine-0.3.4-underlinking.patch
new file mode 100644
index 000000000000..50fe45e23bcc
--- /dev/null
+++ b/media-sound/timemachine/files/timemachine-0.3.4-underlinking.patch
@@ -0,0 +1,24 @@
+diff --git a/configure.ac b/configure.ac
+index dfc8df7..0208487 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,6 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+
+-AC_INIT(configure.in)
++AC_INIT(configure.ac)
+ AM_INIT_AUTOMAKE(timemachine, 0.3.4)
+ AM_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
+@@ -10,6 +10,11 @@ AC_PROG_CC
+ AM_PROG_CC_STDC
+ AC_HEADER_STDC
+
++dnl Check for libm for log10()
++AC_SEARCH_LIBS([log10], [m], [], [
++ AC_MSG_ERROR([unable to find the log10() function])
++])
++
+ PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.0.0])
+ PKG_CHECK_MODULES(JACK, [jack >= 0.80.0])
+ PKG_CHECK_MODULES(LIBLO, liblo >= 0.24, LO_FOUND="yes", LO_FOUND="no")
diff --git a/media-sound/timemachine/timemachine-0.3.4.ebuild b/media-sound/timemachine/timemachine-0.3.4.ebuild
new file mode 100644
index 000000000000..459c251e230a
--- /dev/null
+++ b/media-sound/timemachine/timemachine-0.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop xdg
+
+DESCRIPTION="JACK client record button remembering the last 10 seconds when pressed"
+HOMEPAGE="http://plugin.org.uk/timemachine/"
+SRC_URI="https://github.com/swh/timemachine/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="lash"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ virtual/jack
+ x11-libs/gtk+:2
+ media-libs/liblo
+ >=media-libs/libsndfile-1.0.5
+ lash? ( >=media-sound/lash-0.5 )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-underlinking.patch" )
+
+src_prepare() {
+ mv configure.{in,ac} || die
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ newicon pixmaps/timemachine-icon.png "${PN}.png"
+
+ make_desktop_entry timemachine "TimeMachine Recording" timemachine
+}