summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-07 01:16:57 +0000
committerSam James <sam@gentoo.org>2021-01-07 01:16:57 +0000
commit4071642e177ae0e7289d684387d1f01af563cbd1 (patch)
tree6b67ee6b2b9d5d06bc49e1f46edff2f4b028af2a /media-sound/timidity++/files
parentnet-misc/iperf: cleanup old (diff)
downloadgentoo-4071642e177ae0e7289d684387d1f01af563cbd1.tar.gz
gentoo-4071642e177ae0e7289d684387d1f01af563cbd1.tar.bz2
gentoo-4071642e177ae0e7289d684387d1f01af563cbd1.zip
media-sound/timidity++: cleanup old
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/timidity++/files')
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-CVE-2017-11546.patch31
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-CVE-2017-11547.patch67
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-gcc5.patch31
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-pkg-config.patch109
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch28
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch13
6 files changed, 0 insertions, 279 deletions
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-CVE-2017-11546.patch b/media-sound/timidity++/files/timidity++-2.14.0-CVE-2017-11546.patch
deleted file mode 100644
index 94135e98b96a..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-CVE-2017-11546.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 2386ec2c745f6c5075e53ea051da211336b44b84 Mon Sep 17 00:00:00 2001
-From: Takashi Iwai <tiwai@suse.de>
-Date: Tue, 26 Jun 2018 22:31:27 +0200
-Subject: readmidi: Fix division by zero
-
-References: CVE-2017-11546
-
-An adhoc fix for division by zero in insert_note_steps().
-
-Signed-off-by: Takashi Iwai <tiwai@suse.de>
-bug-debian: https://bugs.debian.org/870338
-bug-suse: https://bugzilla.suse.com/show_bug.cgi?id=1081694
-bug: https://bugzilla.suse.com/show_bug.cgi?id=1081694
-origin: https://bugzilla.suse.com/attachment.cgi?id=760825
----
- timidity/readmidi.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/timidity/readmidi.c b/timidity/readmidi.c
-index 158388a..341777e 100644
---- a/timidity/readmidi.c
-+++ b/timidity/readmidi.c
-@@ -4585,6 +4585,8 @@ static void insert_note_steps(void)
- if (beat != 0)
- meas++, beat = 0;
- num = timesig[n].a, denom = timesig[n].b, n++;
-+ if (!denom)
-+ denom = 1;
- }
- a = (meas + 1) & 0xff;
- b = (((meas + 1) >> 8) & 0x0f) + ((beat + 1) << 4);
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-CVE-2017-11547.patch b/media-sound/timidity++/files/timidity++-2.14.0-CVE-2017-11547.patch
deleted file mode 100644
index 12562a577e0e..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-CVE-2017-11547.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 34328d22cbb4ccf03f29223f54f1834c796d86a2 Mon Sep 17 00:00:00 2001
-From: Takashi Iwai <tiwai@suse.de>
-Date: Tue, 26 Jun 2018 22:31:28 +0200
-Subject: resample: Fix out-of-bound access in resamplers
-
-References: CVE-2017-11547
-
-An adhoc fix for out-of-bound accesses in resamples.
-The offset might overflow the given data range.
-
-Signed-off-by: Takashi Iwai <tiwai@suse.de>
-bug-debian: https://bugs.debian.org/870338
-bug-suse: https://bugzilla.suse.com/show_bug.cgi?id=1081694
-origin: https://bugzilla.suse.com/attachment.cgi?id=760826
----
- timidity/resample.c | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/timidity/resample.c b/timidity/resample.c
-index cd6b8e6..4a3fadf 100644
---- a/timidity/resample.c
-+++ b/timidity/resample.c
-@@ -57,6 +57,8 @@ static resample_t resample_cspline(sample_t *src, splen_t ofs, resample_rec_t *r
- {
- int32 ofsi, ofsf, v0, v1, v2, v3, temp;
-
-+ if (ofs + (1 << FRACTION_BITS) >= rec->data_length)
-+ return src[ofs >> FRACTION_BITS];
- ofsi = ofs >> FRACTION_BITS;
- v1 = src[ofsi];
- v2 = src[ofsi + 1];
-@@ -96,6 +98,8 @@ static resample_t resample_lagrange(sample_t *src, splen_t ofs, resample_rec_t *
- {
- int32 ofsi, ofsf, v0, v1, v2, v3;
-
-+ if (ofs + (1 << FRACTION_BITS) >= rec->data_length)
-+ return src[ofs >> FRACTION_BITS];
- ofsi = ofs >> FRACTION_BITS;
- v1 = (int32)src[ofsi];
- v2 = (int32)src[ofsi + 1];
-@@ -154,6 +158,8 @@ static resample_t resample_gauss(sample_t *src, splen_t ofs, resample_rec_t *rec
- sample_t *sptr;
- int32 left, right, temp_n;
-
-+ if (ofs + (1 << FRACTION_BITS) >= rec->data_length)
-+ return src[ofs >> FRACTION_BITS];
- left = (ofs>>FRACTION_BITS);
- right = (rec->data_length>>FRACTION_BITS) - left - 1;
- temp_n = (right<<1)-1;
-@@ -261,6 +267,8 @@ static resample_t resample_newton(sample_t *src, splen_t ofs, resample_rec_t *re
- int32 left, right, temp_n;
- int ii, jj;
-
-+ if (ofs + (1 << FRACTION_BITS) >= rec->data_length)
-+ return src[ofs >> FRACTION_BITS];
- left = (ofs>>FRACTION_BITS);
- right = (rec->data_length>>FRACTION_BITS)-(ofs>>FRACTION_BITS)-1;
- temp_n = (right<<1)-1;
-@@ -330,6 +338,8 @@ static resample_t resample_linear(sample_t *src, splen_t ofs, resample_rec_t *re
- {
- int32 v1, v2, ofsi;
-
-+ if (ofs + (1 << FRACTION_BITS) >= rec->data_length)
-+ return src[ofs >> FRACTION_BITS];
- ofsi = ofs >> FRACTION_BITS;
- v1 = src[ofsi];
- v2 = src[ofsi + 1];
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-gcc5.patch b/media-sound/timidity++/files/timidity++-2.14.0-gcc5.patch
deleted file mode 100644
index 50d64e3bcbb5..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-gcc5.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Upstream commit 6e189f6073e979ceccaf05c3bb5f495a1b9ed87e
-
-inline, defaults to "extern inline" with newer gcc versions
-
-With newer versions of gcc, "inline" defaults to extern, and not static if
-not specified. This causes linking problems at the end of the compile. Most
-of this occurences are fixed (or #ifdef'ed away) except these two small
-ones in timidity/mfi.c
-
-Signed-off-by: Stian Skjelstad <stian.skjelstad@...>
-
---- a/timidity/mfi.c 2004-02-17 17:02:18.000000000 +0100
-+++ b/timidity/mfi.c 2017-02-14 04:41:24.000000000 +0100
-@@ -344,7 +344,7 @@
- #define SEND_LASTNOTEINFO(lni, ch) if (LASTNOTEINFO_HAS_DATA((lni)[ch])) SendLastNoteInfo(lni, ch);
- #define SEND_AND_CLEAR_LASTNOTEINFO(lni, ch) if (LASTNOTEINFO_HAS_DATA((lni)[ch])) { SendLastNoteInfo(lni, ch); (lni)[ch].on = NO_LAST_NOTE_INFO; }
-
--inline void StoreLastNoteInfo(LastNoteInfo *info, int channel, int time, int duration, int note, int velocity)
-+static inline void StoreLastNoteInfo(LastNoteInfo *info, int channel, int time, int duration, int note, int velocity)
- {
- info[channel].on = time;
- info[channel].off = time + duration;
-@@ -352,7 +352,7 @@
- info[channel].velocity = velocity;
- }
-
--inline void SendLastNoteInfo(const LastNoteInfo *info, int channel)
-+static inline void SendLastNoteInfo(const LastNoteInfo *info, int channel)
- {
- NOTE_BUF_EV_DEBUGSTR(channel, info[channel].on, note_name[info[channel].note % 12], info[channel].note / 12, info[channel].velocity, info[channel].off);
- MIDIEVENT(info[channel].on, ME_NOTEON, channel, info[channel].note, info[channel].velocity);
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-pkg-config.patch b/media-sound/timidity++/files/timidity++-2.14.0-pkg-config.patch
deleted file mode 100644
index 15d6a4ec43f4..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-pkg-config.patch
+++ /dev/null
@@ -1,109 +0,0 @@
-use $PKG_CONFIG rather than `pkg-config`
-
-https://bugs.gentoo.org/497362
-get ncurses info via pkg-config while we're at it
-
-patch by Mike Frysinger <vapier@gentoo.org>
-
---- a/configure.in
-+++ b/configure.in
-@@ -148,6 +148,7 @@ AC_SUBST(xawresdir)
-
- # Checks for programs.
- AM_PATH_LISPDIR
-+PKG_PROG_PKG_CONFIG
- AC_PROG_CC
- AC_PROG_GCC_TRADITIONAL
- AC_PROG_INSTALL
-@@ -1318,8 +1319,8 @@ AC_MSG_CHECKING(enable_audio=jack)
- if test "x$au_enable_jack" = xyes; then
- AC_MSG_RESULT(yes)
- SYSEXTRAS="$SYSEXTRAS jack_a.c"
-- EXTRALIBS="$EXTRALIBS $(pkg-config --libs jack)"
-- EXTRADEFS="$EXTRADEFS -DAU_JACK $(pkg-config --cflags jack)"
-+ EXTRALIBS="$EXTRALIBS $(${PKG_CONFIG} --libs jack)"
-+ EXTRADEFS="$EXTRADEFS -DAU_JACK $(${PKG_CONFIG} --cflags jack)"
- else
- AC_MSG_RESULT(no)
- fi
-@@ -1635,60 +1636,8 @@ dnl ncurses
- AM_CONDITIONAL(ENABLE_NCURSES, false)
- CONFIG_INTERFACE(ncurses,NCURSES,n,
- AS_HELP_STRING([--enable-ncurses], [Enable ncurses interface (default is no)]),
-- [ AC_CHECK_HEADERS(ncurses.h ncurses/curses.h curses.h)
--
--dnl #include <ncurses/curses.h> is failure on Plamo Linux 1.3/ncurses 1.9.9e
--dnl because <ncurses/curses.h> includes <unctrl.h>:
--dnl /usr/include/ncurses/curses.h:34: unctrl.h: No such file or directory
--dnl But surely there is unctl.h at /usr/include/ncurses/unctrl.h.
--dnl configure must check ncurses header with -I/usr/include/ncurses option.
--
-- case "$ac_cv_header_curses_h$ac_cv_header_ncurses_curses_h$ac_cv_header_ncurses_h" in
-- *yes*);;
-- *) for i in /usr/include /usr/local/include; do
-- if test -f "$i/ncurses/curses.h" -a -f "$i/ncurses/unctrl.h"; then
-- AC_MSG_WARN(ncurses test is failure. Please check config.h and common.makefile later)
-- CPPFLAGS="$CPPFLAGS -I$i/ncurses"
-- break
-- fi
-- done
-- ;;
-- esac
--
-- AC_CHECK_LIB(ncurses,initscr,lib_curses_opt=-lncurses,
-- [ dnl checking pdcurses
-- AC_CHECK_LIB(curses,PDC_set_ctrl_break,
-- [ lib_curses_opt=-lcurses
-- AC_DEFINE(USE_PDCURSES,1,Define to 1 if you use PDcurses)
-- lib_user32_opt="$lib_user32_test"
-- ],
-- [ dnl checking libpdcurses
-- AC_CHECK_LIB(pdcurses,PDC_set_ctrl_break,
-- [ lib_curses_opt=-lpdcurses
-- AC_DEFINE(USE_PDCURSES,1,Define to 1 if you use PDcurses)
-- lib_user32_opt="$lib_user32_test"
-- ],
-- [ dnl OpenBSD use -lcurses instead of -lncurses.
-- case "$target" in
-- *openbsd*)
-- AC_CHECK_LIB(curses,initscr,lib_curses_opt=-lcurses,
-- [ AC_MSG_WARN(ncurses interface is not enabled)
-- enable_ncurses=no ])
-- ;;
-- *)
-- if test "x$VCPP" = xyes || test "x$BORLANDC" = xyes || test "x$WATCOM_C" = xyes || test "x$DMC" = xyes || test "x$POCC" = xyes; then
-- lib_curses_opt=libpdcurses.lib
-- AC_DEFINE(USE_PDCURSES,1,Define to 1 if you use PDcurses)
-- else
-- AC_MSG_WARN(ncurses interface is not enabled)
-- enable_ncurses=no
-- fi
-- ;;
-- esac
-- ])
-- ],
-- $lib_user32_test)
-- ])
-+ [ CPPFLAGS="$CPPFLAGS $(${PKG_CONFIG} --cflags ncurses)"
-+ lib_curses_opt=$(${PKG_CONFIG} --libs ncurses)
- ],
- [ LIBS="$LIBS $lib_curses_opt"
- case "$target" in
-@@ -1855,7 +1804,7 @@ CONFIG_INTERFACE(xaw,XAW,a,
- lib_xmu_opt=-lXmu
- lib_xt_opt=-lXt
- if test "x$enable_xft" = "xyes" && test "x$have_xaw" != "xno"; then
-- XFT_CFLAGS="$(pkg-config --cflags xft)";
-+ XFT_CFLAGS="$(${PKG_CONFIG} --cflags xft)";
- EXTRACT_CPPFLAGS(CPPFLAGS,CFLAGS,$XFT_CFLAGS)
- lib_xft_opt="-lXft";
- fi
-@@ -1909,7 +1858,7 @@ CONFIG_INTERFACE(xaw,XAW,a,
- ;;
- esac
- if test "x$enable_xft" = "xyes" && test "x$have_xaw" != "xno"; then
-- XFT_CFLAGS="$(pkg-config --cflags xft)";
-+ XFT_CFLAGS="$(${PKG_CONFIG} --cflags xft)";
- EXTRACT_CPPFLAGS(CPPFLAGS,CFLAGS,$XFT_CFLAGS)
- a_so_libs="$a_so_libs -lXft";
- fi
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch b/media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch
deleted file mode 100644
index 6f901eab8bc0..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-This will revert part of the commit from:
-
-http://timidity.git.sourceforge.net/git/gitweb.cgi?p=timidity/timidity;a=commit;h=e73b53437dbc1e57e61dd4d0c1407784797b08d9
-
-Because otherwise TiMidity++ simply won't build as per:
-
-../interface/libinterface.a(xskin_c.o): In function `ctl_event':
-xskin_c.c:(.text+0x17c): undefined reference to `ctl_speana_data'
-collect2: error: ld returned 1 exit status
-
---- a/interface/xskin_c.c
-+++ b/interface/xskin_c.c
-@@ -228,7 +228,6 @@
- }
- }
-
--#if 0
- static void ctl_speana_data(double *val, int size) {
-
- /* 0 <= val[n] <= (AMP*NCOLOR) */
-@@ -280,7 +279,6 @@
-
- return;
- }
--#endif
-
- /*ARGSUSED*/
- static int ctl_open(int using_stdin, int using_stdout) {
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch b/media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch
deleted file mode 100644
index 23ef62aa03e5..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://bugs.gentoo.org/451296
-
---- a/interface/tk_c.c
-+++ b/interface/tk_c.c
-@@ -913,7 +913,7 @@
- vsnprintf(buf, sizeof(buf), fmt, ap);
- Tcl_Eval(my_interp, buf);
- va_end(ap);
-- return my_interp->result;
-+ return Tcl_GetStringResult(my_interp);
- }
-
- static const char *v_get2(const char *v1, const char *v2)