summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-10-04 20:10:24 +0200
committerJohannes Huber <johu@gentoo.org>2017-10-04 20:10:24 +0200
commitd261485b3b50c72f14c4d33f6a792470505f34e1 (patch)
tree23c39fa51ec4fe1f6a80ce60b7c5906938274734 /media-sound/tomahawk/files
parentmail-client/neomutt: Rename smime_keys (diff)
downloadgentoo-d261485b3b50c72f14c4d33f6a792470505f34e1.tar.gz
gentoo-d261485b3b50c72f14c4d33f6a792470505f34e1.tar.bz2
gentoo-d261485b3b50c72f14c4d33f6a792470505f34e1.zip
media-sound/tomahawk: Fix qtkeychain detection
Closes: https://bugs.gentoo.org/633470 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'media-sound/tomahawk/files')
-rw-r--r--media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch b/media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch
new file mode 100644
index 000000000000..e4b3bf0304c9
--- /dev/null
+++ b/media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch
@@ -0,0 +1,28 @@
+From 00f602e10203b76fc28b4615868c567e6bd4ced4 Mon Sep 17 00:00:00 2001
+From: Dominik Schmidt <dev@dominik-schmidt.de>
+Date: Tue, 8 Aug 2017 14:34:49 +0200
+Subject: [PATCH] Fix #619: Correctly detect qt5keychain
+
+---
+ CMakeLists.txt | 8 ++------
+ 1 file changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ad5d918ecf..7004e1b700 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -376,12 +376,8 @@ macro_optional_find_package(LibLastFm 1.0.0)
+ macro_log_feature(LIBLASTFM_FOUND "liblastfm" "Qt library for the Last.fm webservices" "https://github.com/lastfm/liblastfm" TRUE "" "liblastfm is needed for scrobbling tracks to Last.fm and fetching cover artwork")
+
+ if( NOT APPLE )
+-if( TOMAHAWK_QT5 )
+- macro_optional_find_package(Qt5Keychain 0.1.0)
+-else()
+- macro_optional_find_package(QtKeychain 0.1.0)
+-endif()
+-macro_log_feature(QTKEYCHAIN_FOUND "QtKeychain" "Provides support for secure credentials storage" "https://github.com/frankosterfeld/qtkeychain" TRUE "" "")
++macro_optional_find_package(Qt5Keychain 0.1.0)
++macro_log_feature(Qt5Keychain_FOUND "QtKeychain" "Provides support for secure credentials storage" "https://github.com/frankosterfeld/qtkeychain" TRUE "" "")
+ endif()
+
+ if( UNIX AND NOT APPLE )