summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-02 04:17:31 +0000
committerSam James <sam@gentoo.org>2021-12-02 04:43:13 +0000
commit382751f8f2a3eca9691a976dc4f5e8a1558bd30c (patch)
tree0c9ab91ace508580184ce5f3ec767be1a3f6418f /media-sound/ttaenc
parentapp-admin/vault: Remove vulnerable 1.8.4 (diff)
downloadgentoo-382751f8f2a3eca9691a976dc4f5e8a1558bd30c.tar.gz
gentoo-382751f8f2a3eca9691a976dc4f5e8a1558bd30c.tar.bz2
gentoo-382751f8f2a3eca9691a976dc4f5e8a1558bd30c.zip
media-sound/ttaenc: fix build on musl
Closes: https://bugs.gentoo.org/646188 Thanks-to: Randy Palamar <palamar.randy@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/ttaenc')
-rw-r--r--media-sound/ttaenc/files/ttaenc-3.4.1-fix-musl.patch22
-rw-r--r--media-sound/ttaenc/ttaenc-3.4.1-r1.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/media-sound/ttaenc/files/ttaenc-3.4.1-fix-musl.patch b/media-sound/ttaenc/files/ttaenc-3.4.1-fix-musl.patch
new file mode 100644
index 000000000000..674782fec91f
--- /dev/null
+++ b/media-sound/ttaenc/files/ttaenc-3.4.1-fix-musl.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/646188
+--- a/ttaenc.h
++++ b/ttaenc.h
+@@ -41,6 +41,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
++#include <stdint.h>
+ #endif
+
+ #ifdef _MSC
+@@ -101,8 +102,8 @@
+ typedef unsigned __int32 uint32;
+ typedef unsigned __int64 uint64;
+ #else
+-typedef __uint32_t uint32;
+-typedef __uint64_t uint64;
++typedef uint32_t uint32;
++typedef uint64_t uint64;
+ #endif
+
+ #define PREDICTOR1(x, k) ((int)((((uint64)x << k) - x) >> k))
diff --git a/media-sound/ttaenc/ttaenc-3.4.1-r1.ebuild b/media-sound/ttaenc/ttaenc-3.4.1-r1.ebuild
index 833e61d88d20..14a901304cbf 100644
--- a/media-sound/ttaenc/ttaenc-3.4.1-r1.ebuild
+++ b/media-sound/ttaenc/ttaenc-3.4.1-r1.ebuild
@@ -8,15 +8,16 @@ inherit toolchain-funcs
DESCRIPTION="True Audio Compressor Software"
HOMEPAGE="http://tta.sourceforge.net"
SRC_URI="mirror://sourceforge/tta/${P}-src.tgz"
+S="${WORKDIR}/${P}-src"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-S="${WORKDIR}/${P}-src"
PATCHES=(
"${FILESDIR}"/${P}-fix-build-system.patch
"${FILESDIR}"/${P}-fix-hybrid-filter.patch
+ "${FILESDIR}"/${P}-fix-musl.patch
)
src_configure() {