summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChrisADR <christopher.diaz.riv@gmail.com>2017-07-16 19:26:28 -0500
committerAlexis Ballier <aballier@gentoo.org>2017-07-17 17:53:30 +0200
commit3aeef28be917bba491ddb751f06aec58fdf672a9 (patch)
tree892f307fea5c1860c46963bc34a5f4dde48d1dab /media-sound/vorbis-tools/vorbis-tools-1.4.0-r3.ebuild
parentkde-frameworks/kxmlgui: keyword ~arm64 (diff)
downloadgentoo-3aeef28be917bba491ddb751f06aec58fdf672a9.tar.gz
gentoo-3aeef28be917bba491ddb751f06aec58fdf672a9.tar.bz2
gentoo-3aeef28be917bba491ddb751f06aec58fdf672a9.zip
media-sound/vorbis-tools: New revision fixing security bug 559170
Diffstat (limited to 'media-sound/vorbis-tools/vorbis-tools-1.4.0-r3.ebuild')
-rw-r--r--media-sound/vorbis-tools/vorbis-tools-1.4.0-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/vorbis-tools/vorbis-tools-1.4.0-r3.ebuild b/media-sound/vorbis-tools/vorbis-tools-1.4.0-r3.ebuild
new file mode 100644
index 000000000000..977e7e88ff3f
--- /dev/null
+++ b/media-sound/vorbis-tools/vorbis-tools-1.4.0-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="tools for using the Ogg Vorbis sound file format"
+HOMEPAGE="http://www.vorbis.com"
+SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="flac kate nls +ogg123 speex"
+
+RDEPEND=">=media-libs/libvorbis-1.3.0
+ flac? ( media-libs/flac )
+ kate? ( media-libs/libkate )
+ ogg123? (
+ >=media-libs/libao-1.0.0
+ net-misc/curl
+ )
+ speex? ( media-libs/speex )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+DOCS="AUTHORS CHANGES README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+ epatch "${FILESDIR}"/${P}-format-security.patch
+ epatch "${FILESDIR}"/${P}-aiff-buffer-overflow.patch
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #515220
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ogg123) \
+ $(use_with flac) \
+ $(use_with speex) \
+ $(use_with kate)
+}