summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Denisov <pavel.a.denisov@gmail.com>2016-06-30 22:51:20 -0400
committerDavid Seifert <soap@gentoo.org>2016-07-02 15:23:45 +0200
commitc9582c99ee2f9dd3053b9c48db1efc957566c61c (patch)
treef0e199f5bbcb1124fdea0ea526c1c7bac72206f7 /media-sound/wav2json/wav2json-0.4.ebuild
parentdev-python/pycipher: remove old and deprecated (diff)
downloadgentoo-c9582c99ee2f9dd3053b9c48db1efc957566c61c.tar.gz
gentoo-c9582c99ee2f9dd3053b9c48db1efc957566c61c.tar.bz2
gentoo-c9582c99ee2f9dd3053b9c48db1efc957566c61c.zip
media-sound/wav2json: new ebuild
Closes: https://github.com/gentoo/gentoo/pull/1809 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/wav2json/wav2json-0.4.ebuild')
-rw-r--r--media-sound/wav2json/wav2json-0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/wav2json/wav2json-0.4.ebuild b/media-sound/wav2json/wav2json-0.4.ebuild
new file mode 100644
index 000000000000..90440452cead
--- /dev/null
+++ b/media-sound/wav2json/wav2json-0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+COMMIT_ID="e412923f1f792408e8ae1096ca40fb5307ddfc74"
+DESCRIPTION="Generate waveformjs.org compatible json data out of wav files"
+HOMEPAGE="https://github.com/beschulz/wav2json"
+SRC_URI="https://github.com/beschulz/wav2json/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+S=${WORKDIR}/${PN}-${COMMIT_ID}/build
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/boost:=
+ media-libs/libsndfile
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ../bin/Linux/wav2json
+}