summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-04 20:21:13 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-07 14:12:15 +0200
commit71a91badf76c98bc221687a406ca25ab4a411b5e (patch)
treea2dfed5b79ca6c966d4366082e5f2b2268ef476c /media-sound/wavsplit/wavsplit-1.2.1-r2.ebuild
parentmedia-sound/tempest_for_eliza: EAPI7 revbump, improve ebuild (diff)
downloadgentoo-71a91badf76c98bc221687a406ca25ab4a411b5e.tar.gz
gentoo-71a91badf76c98bc221687a406ca25ab4a411b5e.tar.bz2
gentoo-71a91badf76c98bc221687a406ca25ab4a411b5e.zip
media-sound/wavsplit: EAPI7 revbump, improve ebuild
Closes: https://bugs.gentoo.org/665234 Closes: https://github.com/gentoo/gentoo/pull/9777
Diffstat (limited to 'media-sound/wavsplit/wavsplit-1.2.1-r2.ebuild')
-rw-r--r--media-sound/wavsplit/wavsplit-1.2.1-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/wavsplit/wavsplit-1.2.1-r2.ebuild b/media-sound/wavsplit/wavsplit-1.2.1-r2.ebuild
new file mode 100644
index 000000000000..7e422e4d3fa0
--- /dev/null
+++ b/media-sound/wavsplit/wavsplit-1.2.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line tool to split WAV files"
+HOMEPAGE="https://sourceforge.net/projects/wavsplit/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+#-sparc, -amd64: 1.0: "Only supports PCM wave format" error message.
+KEYWORDS="~amd64 -sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Makefile.patch
+ "${FILESDIR}"/${P}-large-files.patch
+ "${FILESDIR}"/${P}-64bit.patch
+)
+
+src_prepare() {
+ default
+ emake clean
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_test() { :; } #294302
+
+src_install() {
+ dobin wav{ren,split}
+ doman wav{ren,split}.1
+ dodoc BUGS CHANGES CREDITS README{,.wavren}
+}