summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2017-11-16 00:31:37 +0000
committerDenis Dupeyron <calchan@gentoo.org>2017-11-16 00:33:08 +0000
commit57090858d6ccfa934cd8760d246605f7ea9f2ad9 (patch)
tree9ded4d254a242e95605c86d9b40f046834a0ce96 /media-sound/xfmpc/xfmpc-0.2.3-r1.ebuild
parentnet-irc/konversation: Drop 1.7.3 (diff)
downloadgentoo-57090858d6ccfa934cd8760d246605f7ea9f2ad9.tar.gz
gentoo-57090858d6ccfa934cd8760d246605f7ea9f2ad9.tar.bz2
gentoo-57090858d6ccfa934cd8760d246605f7ea9f2ad9.zip
Remove obsolete xfconf.eclass and migrate to EAPI6
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'media-sound/xfmpc/xfmpc-0.2.3-r1.ebuild')
-rw-r--r--media-sound/xfmpc/xfmpc-0.2.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/xfmpc/xfmpc-0.2.3-r1.ebuild b/media-sound/xfmpc/xfmpc-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..c19bd37ce405
--- /dev/null
+++ b/media-sound/xfmpc/xfmpc-0.2.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="Music Player Daemon (MPD) client for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfmpc"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18:2=
+ >=media-libs/libmpd-0.15:=
+ >=x11-libs/gtk+-2.16:2=
+ >=xfce-base/libxfce4ui-4.8:=
+ >=xfce-base/libxfce4util-4.8:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS=( AUTHORS ChangeLog IDEAS NEWS README THANKS )
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}