summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-04-01 11:29:41 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-04-01 11:31:38 +0200
commitf735768136531837f4d394215871e658a2dc1c17 (patch)
tree51981db62588638f57562b573bf63d9ea9e85d6c /media-sound/yoshimi
parentmedia-sound/yoshimi: Missing manifest (diff)
downloadgentoo-f735768136531837f4d394215871e658a2dc1c17.tar.gz
gentoo-f735768136531837f4d394215871e658a2dc1c17.tar.bz2
gentoo-f735768136531837f4d394215871e658a2dc1c17.zip
media-sound/yoshimi: improvements
1) cmake-utils -> cmake 2) updated dep version 3) quoted vars Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/yoshimi')
-rw-r--r--media-sound/yoshimi/yoshimi-1.7.0.1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-sound/yoshimi/yoshimi-1.7.0.1.ebuild b/media-sound/yoshimi/yoshimi-1.7.0.1.ebuild
index 0f180a38a2fa..e4c00e99a9c0 100644
--- a/media-sound/yoshimi/yoshimi-1.7.0.1.ebuild
+++ b/media-sound/yoshimi/yoshimi-1.7.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils xdg flag-o-matic
+inherit cmake xdg flag-o-matic
DESCRIPTION="Software synthesizer based on ZynAddSubFX"
HOMEPAGE="https://yoshimi.github.io/"
@@ -16,7 +16,7 @@ IUSE="+lv2"
BDEPEND="virtual/pkgconfig"
DEPEND="
- >=dev-libs/mxml-3.1
+ >=dev-libs/mxml-2.5
media-libs/alsa-lib
media-libs/fontconfig
media-libs/libsndfile
@@ -36,16 +36,16 @@ CMAKE_USE_DIR="${WORKDIR}/${P}/src"
DOCS=( Changelog README.txt )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
append-cxxflags -lpthread
append-cppflags -lpthread
}
src_configure() {
local mycmakeargs=( -DLV2Plugin=$(usex lv2) )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
- mv ${D}/usr/share/doc/yoshimi ${D}/usr/share/doc/${P}
+ cmake_src_install
+ mv "${D}"/usr/share/doc/yoshimi "${D}"/usr/share/doc/${P}
}