summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 00:26:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 00:26:59 +0100
commita6410c7da3b8639705122551d2e657bae4ba72f8 (patch)
tree2c62551252fed6d014adce0294a1986f8f1a56d9 /media-sound/zynaddsubfx
parentdev-libs/rocksdb: Stabilize 6.14.6 amd64, #761969 (diff)
downloadgentoo-a6410c7da3b8639705122551d2e657bae4ba72f8.tar.gz
gentoo-a6410c7da3b8639705122551d2e657bae4ba72f8.tar.bz2
gentoo-a6410c7da3b8639705122551d2e657bae4ba72f8.zip
media-sound/zynaddsubfx: Fix cmake with IUSE=jack
Closes: https://bugs.gentoo.org/761823 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/zynaddsubfx')
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-3.0.5-cmake.patch15
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild7
2 files changed, 20 insertions, 2 deletions
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.5-cmake.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.5-cmake.patch
new file mode 100644
index 000000000000..8fbcf9aca56a
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.5-cmake.patch
@@ -0,0 +1,15 @@
+Fix missing CMake include
+
+Authored by:  Simon van der Veldt 2020-09-30
+Committed by:  Mark McCurry 2020-10-03
+
+--- a/src/Nio/CMakeLists.txt
++++ b/src/Nio/CMakeLists.txt
+@@ -21,6 +21,7 @@
+ add_definitions(-DIN_DEFAULT="${DefaultInput}")
+
+ if(JackEnable)
++ include(CheckIncludeFiles)
+ include_directories(${JACK_INCLUDE_DIR})
+ list(APPEND zynaddsubfx_nio_SRCS JackEngine.cpp JackMultiEngine.cpp)
+ list(APPEND zynaddsubfx_nio_lib ${JACK_LIBRARIES})
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild
index 72b005731674..36d58edcadf9 100644
--- a/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild
+++ b/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,7 +38,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-docs.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-docs.patch
+ "${FILESDIR}"/${P}-cmake.patch # bug 761823
+)
DOCS=( ChangeLog HISTORY.txt README.adoc )