summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-09-09 01:00:10 +0300
committerMarek Szuba <marecki@gentoo.org>2016-09-13 10:45:40 +0200
commit05ccefafff83dc9190ac48572116eeab854f3781 (patch)
treef7889a55944c8f01997cee659d8f59a935ffed9a /media-sound
parentmedia-sound/pms: fix numerous QA issues in 0.42-r2 (diff)
downloadgentoo-05ccefafff83dc9190ac48572116eeab854f3781.tar.gz
gentoo-05ccefafff83dc9190ac48572116eeab854f3781.tar.bz2
gentoo-05ccefafff83dc9190ac48572116eeab854f3781.zip
media-sound/pms: live ebuild overhaul
fix ncurses slot dep specify correct license fix automagic dependency on autodoc add missing depends (dev-util/intltool and dev-util/gettext) add missing rdepend on virtual/libintl specify gcc 4.9 as the minimal gcc version Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pms/files/pms-9999-fix-automagic-dep.patch34
-rw-r--r--media-sound/pms/pms-9999.ebuild28
2 files changed, 55 insertions, 7 deletions
diff --git a/media-sound/pms/files/pms-9999-fix-automagic-dep.patch b/media-sound/pms/files/pms-9999-fix-automagic-dep.patch
new file mode 100644
index 000000000000..afb71d130daa
--- /dev/null
+++ b/media-sound/pms/files/pms-9999-fix-automagic-dep.patch
@@ -0,0 +1,34 @@
+From 3771a139059cf248cc07cf8a735c0cd95ae3c6af Mon Sep 17 00:00:00 2001
+From: Mykyta Holubakha <hilobakho@gmail.com>
+Date: Fri, 9 Sep 2016 00:56:22 +0300
+Subject: [PATCH] Fix automagic pandoc dependency
+
+---
+ configure.ac | 11 ++++++++---
+ 1 file changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 45e6d1a..aea9285 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,9 +25,14 @@ PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.0],, [AC_MSG_ERROR([glib 2.0 or newer i
+ PKG_CHECK_MODULES([libmpdclient], [libmpdclient >= 2.5],, [AC_MSG_ERROR([libmpdclient 2.5 or newer is required])])
+
+ # Check for Pandoc
+-AC_PATH_PROG(PANDOC,pandoc,no)
+-if [[ "x$PANDOC" = xno ]]; then
+- AC_MSG_WARN([The manual page will not be built.])
++AC_ARG_WITH([doc], AS_HELP_STRING([--with-doc],[Build the manpage (default: disabled)]))
++if [test "x$with_doc" = "xyes"]; then
++ AC_PATH_PROG(PANDOC,pandoc,no)
++ if [[ "x$PANDOC" = xno ]]; then
++ AC_MSG_WARN([The manual page will not be built.])
++ fi
++else
++ PANDOC="no"
+ fi
+ AM_CONDITIONAL([PANDOC], [test "x$PANDOC" != xno])
+
+--
+2.10.0
+
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
index af181ef46d25..b7aed94e14ae 100644
--- a/media-sound/pms/pms-9999.ebuild
+++ b/media-sound/pms/pms-9999.ebuild
@@ -4,30 +4,43 @@
EAPI=6
-inherit autotools flag-o-matic git-r3
+inherit autotools flag-o-matic git-r3 toolchain-funcs versionator
DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
HOMEPAGE="https://ambientsound.github.io/pms"
EGIT_REPO_URI="https://github.com/ambientsound/pms.git"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-IUSE="regex"
+IUSE="regex doc"
RDEPEND="
- sys-libs/ncurses:=[unicode]
+ sys-libs/ncurses:0=[unicode]
dev-libs/glib:2
media-libs/libmpdclient
+ virtual/libintl
"
DEPEND="
virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ doc? ( app-text/pandoc )
${RDEPEND}
"
DOCS=( AUTHORS README TODO )
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use regex; then
+ if tc-is-gcc && ! version_is_at_least 4.9 $(gcc-version); then
+ die "Clang or GCC >= 4.9 is required for proper regex support"
+ fi
+ fi
+}
+
src_prepare() {
+ eapply "${FILESDIR}/pms-9999-fix-automagic-dep.patch"
eapply_user
eautoreconf
@@ -35,9 +48,10 @@ src_prepare() {
src_configure() {
# Required for ncurses[tinfo]
- append-cppflags $(pkg-config --cflags ncursesw)
- append-libs $(pkg-config --libs ncursesw)
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags ncursesw)
+ append-libs $($(tc-getPKG_CONFIG) --libs ncursesw)
econf \
- $(use_enable regex)
+ $(use_enable regex) \
+ $(use_with doc)
}