summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-24 15:25:58 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-24 15:26:48 -0400
commit1c8ca3692822fe070a8aa920fd06d7398c2b2364 (patch)
tree6910872b0ede21371504107fc498a2a7b43bb64c /media-sound
parentapp-emulation/wine: Stable on amd64 and x86 wrt #591152 (diff)
downloadgentoo-1c8ca3692822fe070a8aa920fd06d7398c2b2364.tar.gz
gentoo-1c8ca3692822fe070a8aa920fd06d7398c2b2364.tar.bz2
gentoo-1c8ca3692822fe070a8aa920fd06d7398c2b2364.zip
media-sound/rplay: new revision with EAPI=6.
The original purpose of this new revision was to fix the use of einstall reported in bug 521564. However, einstall proved necessary, so along with the update to EAPI=6 -- where einstall is banned -- I inlined its behavior. The multilib and eutils eclasses, now unused, were dropped. The latest debian patchset was also included. Package-Manager: portage-2.2.28
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rplay/Manifest1
-rw-r--r--media-sound/rplay/files/rplay-3.3.2-built-in_function_exit-r1.patch20
-rw-r--r--media-sound/rplay/rplay-3.3.2-r2.ebuild53
3 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/rplay/Manifest b/media-sound/rplay/Manifest
index 75a7caf2d6de..d1f1d61b0ecc 100644
--- a/media-sound/rplay/Manifest
+++ b/media-sound/rplay/Manifest
@@ -1,2 +1,3 @@
DIST rplay-3.3.2.tar.gz 480015 SHA256 74265153457a44e1e2f0fa38c59c9b12ea5b684db2c83eb055184f86db81fdd8 SHA512 b0683de0f5dc1483d22ac68c0502fe66e89ba1c25300fdca9486df1cb6ea96393b18b783f918f18dba0ba0fbfd20410448e3e03df06fc4afba1b63024d82a713 WHIRLPOOL d23479b9809b566c634e8a1574229567e16c81fc943185a99667c373caf02d174c0ab6b2c6437ff5e960d034110c0e480565bbdc8ce436e51970487e64d80bf0
DIST rplay_3.3.2-12.diff.gz 25322 SHA256 9f38ea87379e915ffb3fb338baf454f7ce2cbc605616c27b82df25f708220626 SHA512 b9a178fbca44cec9814ef0b65e4924e18c053ec6f0024c30b35abbcd9062c094bfffe3ca7113c74604df80b12b38d412a45c645ff13903e6b23500ea99f89d7b WHIRLPOOL 8d97ca2cc143b58ead591701709be4922fb0b3c83f2f00c9bb4b8687fe5b937d011e9b9ecc01f9682677d0c84e1ddb03ed510356126939a2d10fe70a536690c1
+DIST rplay_3.3.2-16.debian.tar.xz 25456 SHA256 3c0e1dd8b107d1194ff7b73578281622a1bce97a3a21681d4e124e5c00977d62 SHA512 8d5db7862267fd0ec7f27896b6a76708304e54b9f2c8a52621c0a92c4688511e07a7820b2468c93032dab15f27f5dda1f8931e35d95e724501e2586a5851486b WHIRLPOOL b8e566dd3a407fe2685b084537122b20944b9c0eaf33ea8f15ccd941fc2beaeffdf83ea54394e274d9e4f332b449230d9e0a5d3ca3b7e060accae70b45ca4677
diff --git a/media-sound/rplay/files/rplay-3.3.2-built-in_function_exit-r1.patch b/media-sound/rplay/files/rplay-3.3.2-built-in_function_exit-r1.patch
new file mode 100644
index 000000000000..79d9a128806e
--- /dev/null
+++ b/media-sound/rplay/files/rplay-3.3.2-built-in_function_exit-r1.patch
@@ -0,0 +1,20 @@
+--- a/adpcm/decode.c
++++ b/adpcm/decode.c
+@@ -6,6 +6,7 @@
+ * Usage : decode [-3|4|5] [-a|u|l] < infile > outfile
+ */
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "g72x.h"
+
+
+--- a/adpcm/encode.c
++++ b/adpcm/encode.c
+@@ -6,6 +6,7 @@
+ * Usage : encode [-3|4|5] [-a|u|l] < infile > outfile
+ */
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "g72x.h"
+
+
diff --git a/media-sound/rplay/rplay-3.3.2-r2.ebuild b/media-sound/rplay/rplay-3.3.2-r2.ebuild
new file mode 100644
index 000000000000..823271ffd02f
--- /dev/null
+++ b/media-sound/rplay/rplay-3.3.2-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools user
+
+DESCRIPTION="Play sounds on remote Unix systems without data transfer"
+HOMEPAGE="http://rplay.doit.org/"
+SRC_URI="${HOMEPAGE}dist/${P}.tar.gz
+ mirror://debian/pool/main/r/${PN}/${PN}_${PV}-16.debian.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-sound/gsm"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${WORKDIR}/debian/patches"
+ "${FILESDIR}/${P}-built-in_function_exit-r1.patch"
+)
+
+pkg_setup() {
+ enewgroup rplayd ""
+ enewuser rplayd "" "" "" rplayd
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-rplayd-user=rplayd \
+ --enable-rplayd-group=rplayd
+}
+
+src_install() {
+ # This is borrowed from the old einstall helper, and is necessary
+ # (at least some of variables).
+ emake prefix="${ED}/usr" \
+ datadir="${ED}/usr/share" \
+ infodir="${ED}/usr/share/info" \
+ localstatedir="${ED}/var/lib" \
+ mandir="${ED}/usr/share/man" \
+ sysconfdir="${ED}/etc" \
+ install
+}