summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-18 16:31:49 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-18 16:32:02 +0200
commit22e8fe9d148be427cd278dbc7de4b512e744627a (patch)
tree708fe6524b92e97e8630176fd8f08c54c10d3b14 /media-sound
parentsys-libs/ncurses: sparc stable wrt bug #690050 (diff)
downloadgentoo-22e8fe9d148be427cd278dbc7de4b512e744627a.tar.gz
gentoo-22e8fe9d148be427cd278dbc7de4b512e744627a.tar.bz2
gentoo-22e8fe9d148be427cd278dbc7de4b512e744627a.zip
media-sound/gom: Fixed build with sys-libs/ncurses[tinfo]
Closes: https://bugs.gentoo.org/690092 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/gom/files/gom-0.29.103-tinfo.patch29
-rw-r--r--media-sound/gom/gom-0.29.103-r1.ebuild25
2 files changed, 46 insertions, 8 deletions
diff --git a/media-sound/gom/files/gom-0.29.103-tinfo.patch b/media-sound/gom/files/gom-0.29.103-tinfo.patch
new file mode 100644
index 000000000000..bb93fc2d39cd
--- /dev/null
+++ b/media-sound/gom/files/gom-0.29.103-tinfo.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/690092
+
+--- gom-0.29.103/configure.in
++++ gom-0.29.103/configure.in
+@@ -25,6 +25,7 @@
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
++PKG_PROG_PKG_CONFIG
+
+
+ dnl Custom options to configure
+@@ -39,11 +40,11 @@
+
+ dnl Checks for libraries.
+
+-AC_CHECK_LIB(ncurses, beep)
+-if [[ "$ac_cv_lib_ncurses_beep" != "yes" ]]
+- then AC_MSG_ERROR("Need ncurses library for terminal gomii!")
+-fi
+-
++PKG_CHECK_MODULES(NCURSES, ncurses, [
++ LIBS="$LIBS $NCURSES_LIBS"
++ ],[
++ AC_MSG_ERROR([Need ncurses library for terminal gomii!])
++ ])
+
+ if [[ "$enable_x_gomii" = "yes" ]]; then
+ AC_CHECK_LIB(X11, main)
diff --git a/media-sound/gom/gom-0.29.103-r1.ebuild b/media-sound/gom/gom-0.29.103-r1.ebuild
index 30295a79e97a..b49d71e781ed 100644
--- a/media-sound/gom/gom-0.29.103-r1.ebuild
+++ b/media-sound/gom/gom-0.29.103-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Console Mixer Program for OSS"
HOMEPAGE="http://www.fh-worms.de/~inf222"
@@ -14,15 +14,24 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ~ppc sparc x86"
IUSE="examples"
-DEPEND=">=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2:0="
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-tinfo.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_compile() {
- econf
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed."
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed."
+src_install() {
+ emake DESTDIR="${D}" install
dodoc AUTHORS NEWS ChangeLog README
if use examples; then