summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-22 19:37:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-23 01:25:35 +0100
commit299053dbbf0102616120c63bcf7e8ffc95391ab5 (patch)
tree01c6c90f0f6cc7e9b3161aa93e8c1cdcae8420b2 /media-sound
parentdev-python/pandas: Bump to 1.2.1 (diff)
downloadgentoo-299053dbbf0102616120c63bcf7e8ffc95391ab5.tar.gz
gentoo-299053dbbf0102616120c63bcf7e8ffc95391ab5.tar.bz2
gentoo-299053dbbf0102616120c63bcf7e8ffc95391ab5.zip
media-sound/kmidimon: 1.0.0 version bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/kmidimon/Manifest1
-rw-r--r--media-sound/kmidimon/kmidimon-1.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/kmidimon/Manifest b/media-sound/kmidimon/Manifest
index ebda93d39404..28ef96e899d0 100644
--- a/media-sound/kmidimon/Manifest
+++ b/media-sound/kmidimon/Manifest
@@ -1 +1,2 @@
+DIST kmidimon-1.0.0.tar.bz2 322397 BLAKE2B 6c70e6b6162fe53fbaf7b7945035cb3974120501504c74c3fc0a0c607b2c38153f72cdefdc5f68b97c02148aefc3cd6e49ec0ea45f8b8f9ee6c11ab9383b813d SHA512 3c69fdc128bf5c0b7ec123b06ce3ef0e2220a04e8e721d8fbfa461dc8392b08250f2d333fc0f6080135107a97cd16736327648c4cb4cca72ea4d43c1007ad744
DIST kmidimon-1.0.0_pre20201003.zip 559637 BLAKE2B 57843d2718b8efb6d0be1174390bb21949e200efddc8a7ed65a67eef422eb0976f6008184bdb836bcaa3aabba9a1ea6e2ae848f931a26255a97cc11a29b85643 SHA512 0e6750196a0ecd138746602f6e9c2344aa3fe1ea49a0bb6a40d0626e7a428fb3c8fe51bed76b4df342eef32163c83deffd610bd3904108706943ee6e969b5b26
diff --git a/media-sound/kmidimon/kmidimon-1.0.0.ebuild b/media-sound/kmidimon/kmidimon-1.0.0.ebuild
new file mode 100644
index 000000000000..3c9506e1889b
--- /dev/null
+++ b/media-sound/kmidimon/kmidimon-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="MIDI monitor for ALSA sequencer"
+HOMEPAGE="https://kmidimon.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ >=media-sound/drumstick-2.0.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-qt/linguist-tools:5
+"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+ cmake_src_configure
+}