summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-28 15:28:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-28 16:15:53 +0200
commit324b258d900486d7bbcbd01d15b3982c2bbc671c (patch)
treed629315380776390d8198145c91d8ebfb77d4d84 /media-sound
parentdev-libs/nettle: Stabilize 3.7.2 sparc, #777615 (diff)
downloadgentoo-324b258d900486d7bbcbd01d15b3982c2bbc671c.tar.gz
gentoo-324b258d900486d7bbcbd01d15b3982c2bbc671c.tar.bz2
gentoo-324b258d900486d7bbcbd01d15b3982c2bbc671c.zip
media-sound/drumstick: 2.1.0 version bump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/drumstick/Manifest1
-rw-r--r--media-sound/drumstick/drumstick-2.1.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/media-sound/drumstick/Manifest b/media-sound/drumstick/Manifest
index c48004762c66..5553388faec6 100644
--- a/media-sound/drumstick/Manifest
+++ b/media-sound/drumstick/Manifest
@@ -1 +1,2 @@
DIST drumstick-2.0.0.tar.gz 1865424 BLAKE2B ee87dd222add121c8a6faaac5b8a755e2d6f7b257db890f6bbdbf5380d9771dc5b65a73d716f0cfd343a46c4227adcd2d85e4a359fcaa445b2291dc1ac188cfe SHA512 aacb4ca5a3354da6380ba146ee7ba57e646d19fe6a5d083e00b795221453a87d1baf25965784e7c8a97b9b00a3dda643bce144f62b6a27118f081c681089381a
+DIST drumstick-2.1.0.tar.gz 1875596 BLAKE2B f312c468701a980e5f929aaa02cb20f056f4fad6c2a44100521cf11d4740ffd40656cb424b4b666723b084eb40c5c1963c74554d998515483dda9cfdd62a919c SHA512 b0db307f791fd0014ba7384da293561661b5c242d4fe293e2c604c35ebc03ef6f868448750f7c04b9d6dce6fa2c6d8b548fca4eb70cb63107ae8de8b65c50fd0
diff --git a/media-sound/drumstick/drumstick-2.1.0.ebuild b/media-sound/drumstick/drumstick-2.1.0.ebuild
new file mode 100644
index 000000000000..041eadd01f12
--- /dev/null
+++ b/media-sound/drumstick/drumstick-2.1.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="Qt/C++ wrapper for ALSA sequencer"
+HOMEPAGE="https://drumstick.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fluidsynth pulseaudio"
+
+BDEPEND="
+ dev-libs/libxslt
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+ x11-misc/shared-mime-info
+ doc? (
+ app-doc/doxygen[dot]
+ app-text/docbook-xsl-stylesheets
+ )
+"
+DEPEND="
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ fluidsynth? ( media-sound/fluidsynth )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+RESTRICT="test"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use doc ; then
+ sed -e "/find_package(Doxygen/s/^/# disabled by -doc/" \
+ -i CMakeLists.txt || die
+ fi
+
+ if ! use fluidsynth ; then
+ sed -e "/pkg_check_modules(FLUIDSYNTH/s/^/# disabled by -fluidsynth/" \
+ -i library/rt-backends/CMakeLists.txt || die
+ fi
+
+ if ! use pulseaudio ; then
+ sed -e "/pkg_check_modules(PULSE/s/^/# disabled by -pulseaudio/" \
+ -i CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DUSE_DBUS=ON
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doxygen
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ cmake_src_install
+}