summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-19 23:38:43 +0000
committerSam James <sam@gentoo.org>2022-03-19 23:38:43 +0000
commit4271a34f7b597649c2d034ae0ce00182c837d6d6 (patch)
treee5bd7e555e1ec9dfa8c908ef93c07ddf9777a84a /media-sound
parentgames-fps/eduke32: [QA] fix tc-get* quoting (diff)
downloadgentoo-4271a34f7b597649c2d034ae0ce00182c837d6d6.tar.gz
gentoo-4271a34f7b597649c2d034ae0ce00182c837d6d6.tar.bz2
gentoo-4271a34f7b597649c2d034ae0ce00182c837d6d6.zip
media-sound/sndpeek: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sndpeek/sndpeek-1.41-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-sound/sndpeek/sndpeek-1.41-r1.ebuild b/media-sound/sndpeek/sndpeek-1.41-r1.ebuild
index 8d5d56db8675..bbe0f7e6f139 100644
--- a/media-sound/sndpeek/sndpeek-1.41-r1.ebuild
+++ b/media-sound/sndpeek/sndpeek-1.41-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,8 +39,8 @@ compile_backend() {
backend=$1
cd "${S}/src/sndpeek"
einfo "Compiling against ${backend}"
- emake -f "makefile.${backend}" CC=$(tc-getCC) \
- CXX=$(tc-getCXX)
+ emake -f "makefile.${backend}" CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)"
mv sndpeek{,-${backend}}
emake -f "makefile.${backend}" clean
cd -