summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-08 00:47:19 +0100
committerSam James <sam@gentoo.org>2021-09-08 01:17:33 +0100
commit4f8d31f529aed6f6ca945e86ec77cdb44806f630 (patch)
tree57de99902b3e3e199f3c8e72ca359488e675d9a1 /media-sound
parentsci-libs/gdal: add 3.3.2 (diff)
downloadgentoo-4f8d31f529aed6f6ca945e86ec77cdb44806f630.tar.gz
gentoo-4f8d31f529aed6f6ca945e86ec77cdb44806f630.tar.bz2
gentoo-4f8d31f529aed6f6ca945e86ec77cdb44806f630.zip
media-sound/mpg123: add 1.29.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpg123/Manifest1
-rw-r--r--media-sound/mpg123/mpg123-1.29.0.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index 0312cb8c842c..b4a88867d6f0 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,2 +1,3 @@
DIST mpg123-1.28.1.tar.bz2 1066558 BLAKE2B 4516ed6cafda21aaaf132266b91ae235ca0b911a79c4514c0588c030f4f5f2f3923153729f1fc3354cb5fa982ca8dc27ba6cb58fa884da379a8913c8119e8bd2 SHA512 af1fb96878a7b57f62f06445e9b888cbecc569a91fe118459c71415f62287f9d9de9b0d0663522cb181e1a21692d64d0a810d8aebfa6e085eb76926d7a2186f9
DIST mpg123-1.28.2.tar.bz2 1065867 BLAKE2B 2fc585598e49334b608c2a8487b40b599dc1a57afc53249975a339dbc381b968cc099d4274fb74872d3c4c54d1a6ee1858c4b00c78feb93809c823cc56398661 SHA512 45ac11c5997d13f80917e135a40d2fb4448703dad56271dfe8ce7c8dea339cbac7727ec121779040bd7a07fc4ea79086860ea4a8ec879eda3bdcbf7d57348cda
+DIST mpg123-1.29.0.tar.bz2 1068523 BLAKE2B f044dcdef62156cc34a4709d6ead71042e936d77a86386563862d54d7b18635dd378d4dcac1358228c8275d7bcef894f17432cac0519373d11d4c5f18e346728 SHA512 4261a086395f118f6723d8a3757ebcf5244359be07af634d8bf802e48524978a0974f8b17b423bbf38d262c82ac9e31e0fd5d07a735f63f5e33f58d82dc5fdaf
diff --git a/media-sound/mpg123/mpg123-1.29.0.ebuild b/media-sound/mpg123/mpg123-1.29.0.ebuild
new file mode 100644
index 000000000000..29a2b1f3de75
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.29.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="https://www.mpg123.org/"
+SRC_URI="https://www.mpg123.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+# Note: build system prefers libsdl2 > libsdl. We could in theory add both
+# but it's tricky when it comes to handling switching between them properly.
+# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
+RDEPEND="
+ dev-libs/libltdl:0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl2 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+IDEPEND="app-eselect/eselect-mpg123"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+}
+
+multilib_src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+
+ if $(multilib_is_native_abi) ; then
+ local flag
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+ fi
+
+ use cpu_flags_ppc_altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext
+ # bug #164504
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=(
+ --with-optimization=0
+ --with-audio="${_audio}"
+ --with-default-audio=${_output}
+ --with-cpu=${_cpu}
+ --enable-network
+ $(use_enable ipv6)
+ --enable-int-quality=$(usex int-quality)
+ )
+
+ multilib_is_native_abi || myconf+=( --disable-modules )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123}
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}