summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-03-17 10:06:02 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-03-17 10:06:51 +0100
commit5704924b0a416894684fcd5d02699ca567e02d5b (patch)
tree221bcb563cf817f4bd3691d2079963290c18a867 /media-sound
parentdev-lang/julia: fix build with libgit >=1.4.0 (diff)
downloadgentoo-5704924b0a416894684fcd5d02699ca567e02d5b.tar.gz
gentoo-5704924b0a416894684fcd5d02699ca567e02d5b.tar.bz2
gentoo-5704924b0a416894684fcd5d02699ca567e02d5b.zip
media-sound/qsynth: removed obsolete 0.9.5
Bug: https://bugs.gentoo.org/show_bug.cgi?id=835170 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.9.5.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index db4ee6514f01..77c96d553675 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1,2 +1 @@
-DIST qsynth-0.9.5.tar.gz 331213 BLAKE2B 3973c2ea0599b8bf9f12c3ce1bb7eff00b5d20b4f051ebcb578f556dbfce714cbe0bf77038b553289f27cfedc521bd7e179af652c721375e6bedc4d22ce061d5 SHA512 157e49e8ebfcf550754379c4f2bae221354cffbfe47dcaea747749c00520339f59de5fe7f17e105674ecc6099a98af5f2326d2d258fe359c0c7522366f4267d4
DIST qsynth-0.9.6.tar.gz 334419 BLAKE2B daeb82f102a9a754b708b3d3ebc1963a1cf08180ec16971b4b6fb2ea3b35d7f1ca3a663bd9381d4c90052e1c781a6fef64c4cbf0d456f47ac12791da485979ea SHA512 4f596fefda29fad9298539aaf83bdcc699846416d10b1259041a414f3d89ecc76a6cad338742bac8ffa0ed78ff462fe70147e1ef6437c20241598bd7a1d41a84
diff --git a/media-sound/qsynth/qsynth-0.9.5.ebuild b/media-sound/qsynth/qsynth-0.9.5.ebuild
deleted file mode 100644
index adcfb131ef7b..000000000000
--- a/media-sound/qsynth/qsynth-0.9.5.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake desktop xdg
-
-DESCRIPTION="Qt application to control FluidSynth"
-HOMEPAGE="https://qsynth.sourceforge.io/"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
- inherit git-r3
-else
- SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
- KEYWORDS="amd64 ppc ppc64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+alsa debug jack pulseaudio"
-
-REQUIRED_USE="|| ( alsa jack pulseaudio )"
-
-BDEPEND="
- dev-qt/linguist-tools:5
-"
-DEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
- media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-0.9.1-cmake-no-git-version.patch" )
-
-src_prepare() {
- cmake_src_prepare
-
- sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCONFIG_DEBUG=$(usex debug 1 0)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # The desktop file is invalid, and we also change the command
- # depending on useflags
- rm "${D}/usr/share/applications/org.rncbc.qsynth.desktop" || die
-
- local cmd
- if use jack; then
- cmd="qsynth"
- elif use pulseaudio; then
- cmd="qsynth -a pulseaudio"
- elif use alsa; then
- cmd="qsynth -a alsa"
- else
- cmd="qsynth -a oss"
- fi
-
- make_desktop_entry "${cmd}" Qsynth qsynth
-}