summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-22 05:10:21 +0000
committerSam James <sam@gentoo.org>2021-01-22 05:21:08 +0000
commit5b0da0b48c9d8a41326bafd1fa74c57dfb972717 (patch)
treea781661d9a79b21b6dc24a1a23ea182ad637be27 /media-sound
parentmedia-plugins/gst-plugins-sndio: New Package (diff)
downloadgentoo-5b0da0b48c9d8a41326bafd1fa74c57dfb972717.tar.gz
gentoo-5b0da0b48c9d8a41326bafd1fa74c57dfb972717.tar.bz2
gentoo-5b0da0b48c9d8a41326bafd1fa74c57dfb972717.zip
media-sound/sndio: minor fixups
* Respect EPREFIX * Respect CC * Die on ./configure failure Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sndio/sndio-1.7.0.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/media-sound/sndio/sndio-1.7.0.ebuild b/media-sound/sndio/sndio-1.7.0.ebuild
index d3338773e3ff..24f14c1d8c3a 100644
--- a/media-sound/sndio/sndio-1.7.0.ebuild
+++ b/media-sound/sndio/sndio-1.7.0.ebuild
@@ -1,13 +1,14 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib-minimal
+inherit multilib-minimal toolchain-funcs
DESCRIPTION="small audio and MIDI framework part of the OpenBSD project"
HOMEPAGE="http://www.sndio.org/"
SRC_URI="http://www.sndio.org/${P}.tar.gz"
+
LICENSE="ISC"
SLOT="0/7.0"
KEYWORDS="~amd64"
@@ -28,12 +29,15 @@ src_prepare() {
}
multilib_src_configure() {
+ tc-export CC
+
./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
--privsep-user=sndiod \
--with-libbsd \
- $(use_enable alsa)
+ $(use_enable alsa) \
+ || die "Configure failed"
}
src_install() {