summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSuNova <sunova@tutanota.com>2020-08-11 18:35:59 +0430
committerLars Wendler <polynomial-c@gentoo.org>2020-08-19 12:15:50 +0200
commit6a995cbf618cc337615794215a77a29abdab28d2 (patch)
treec1095ebb9c971398d223362c481e188e952ba991 /media-sound
parentnet-irc/eggdrop: respect LDFLAGS, backport array bounds warning fix (diff)
downloadgentoo-6a995cbf618cc337615794215a77a29abdab28d2.tar.gz
gentoo-6a995cbf618cc337615794215a77a29abdab28d2.tar.bz2
gentoo-6a995cbf618cc337615794215a77a29abdab28d2.zip
media-sound/bluez-alsa: Copy config file to alsa datadir to preserve it
Signed-off-by: sunova <sunova@tutanota.com> Closes: https://github.com/gentoo/gentoo/pull/17079 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-2.1.0-r1.ebuild (renamed from media-sound/bluez-alsa/bluez-alsa-2.1.0.ebuild)4
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild4
-rw-r--r--media-sound/bluez-alsa/files/bluealsa-init.d2
3 files changed, 9 insertions, 1 deletions
diff --git a/media-sound/bluez-alsa/bluez-alsa-2.1.0.ebuild b/media-sound/bluez-alsa/bluez-alsa-2.1.0-r1.ebuild
index c0b3a72b1abb..e81144df9d11 100644
--- a/media-sound/bluez-alsa/bluez-alsa-2.1.0.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-2.1.0-r1.ebuild
@@ -71,6 +71,10 @@ multilib_src_install_all() {
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
systemd_dounit "${FILESDIR}"/bluealsa.service
+
+ # Add config file to alsa datadir as well to preserve changes in /etc
+ insinto "/usr/share/alsa/alsa.conf.d/"
+ doins "src/asound/20-bluealsa.conf"
}
pkg_postinst() {
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
index fc03fb3b79e0..a399d0042c61 100644
--- a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -67,6 +67,10 @@ multilib_src_install_all() {
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
systemd_dounit "${FILESDIR}"/bluealsa.service
+
+ # Add config file to alsa datadir as well to preserve changes in /etc
+ insinto "/usr/share/alsa/alsa.conf.d/"
+ doins "src/asound/20-bluealsa.conf"
}
pkg_postinst() {
diff --git a/media-sound/bluez-alsa/files/bluealsa-init.d b/media-sound/bluez-alsa/files/bluealsa-init.d
index 9b6a3178b63a..087b35386eb6 100644
--- a/media-sound/bluez-alsa/files/bluealsa-init.d
+++ b/media-sound/bluez-alsa/files/bluealsa-init.d
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
pidfile="/var/run/bluealsa.pid"