summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-30 10:29:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-30 10:58:23 +0100
commit733b168e58385abbeaf41f31242d4ae9c12981da (patch)
tree80f60a0b9ab80040162f5a58b62fa9fa730ec449 /media-sound
parentnet-im/psi: EAPI-7 bump (diff)
downloadgentoo-733b168e58385abbeaf41f31242d4ae9c12981da.tar.gz
gentoo-733b168e58385abbeaf41f31242d4ae9c12981da.tar.bz2
gentoo-733b168e58385abbeaf41f31242d4ae9c12981da.zip
media-sound/xwax: EAPI-7 bump, https
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xwax/xwax-1.6.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/media-sound/xwax/xwax-1.6.ebuild b/media-sound/xwax/xwax-1.6.ebuild
index 89ce08abad33..d265c8017b5c 100644
--- a/media-sound/xwax/xwax-1.6.ebuild
+++ b/media-sound/xwax/xwax-1.6.ebuild
@@ -1,35 +1,40 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit toolchain-funcs user
DESCRIPTION="Digital vinyl emulation software"
-HOMEPAGE="http://xwax.org/"
-SRC_URI="http://xwax.org/releases/${P}.tar.gz"
+HOMEPAGE="https://xwax.org/"
+SRC_URI="https://xwax.org/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="alsa jack oss cdda mp3 +fallback"
+
REQUIRED_USE="|| ( cdda mp3 fallback )
|| ( alsa jack oss )"
-RDEPEND="sys-libs/glibc
- sys-libs/pam
+DEPEND="
+ media-fonts/dejavu
media-libs/libsdl
media-libs/sdl-ttf
- media-fonts/dejavu
+ sys-libs/glibc
+ sys-libs/pam
alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
cdda? ( media-sound/cdparanoia )
+ fallback? ( virtual/ffmpeg )
+ jack? ( media-sound/jack-audio-connection-kit )
mp3? ( media-sound/mpg123 )
- fallback? ( virtual/ffmpeg )"
-DEPEND="${RDEPEND}"
+"
+RDEPEND="${DEPEND}"
-DOCS="README CHANGES"
+DOCS=( README CHANGES )
src_prepare() {
+ default
# Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
# the Makefile
# Also remove the dependency on the .version target so we don't need
@@ -42,7 +47,7 @@ src_prepare() {
src_configure() {
tc-export CC
econf \
- --prefix "${EROOT}usr" \
+ --prefix "${EROOT}/usr" \
$(use_enable alsa) \
$(use_enable jack) \
$(use_enable oss)