summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-10-04 03:26:02 +0100
committerMarek Szuba <marecki@gentoo.org>2022-10-04 04:13:02 +0100
commit7dbeecd706f4f9fc157df43bfe660a79d27081ef (patch)
treee97d96bf22be59813bda122fd3dd8a3d82c7d609 /media-sound
parentmedia-sound/linux-show-player: new package, add 0.5.3 (diff)
downloadgentoo-7dbeecd706f4f9fc157df43bfe660a79d27081ef.tar.gz
gentoo-7dbeecd706f4f9fc157df43bfe660a79d27081ef.tar.bz2
gentoo-7dbeecd706f4f9fc157df43bfe660a79d27081ef.zip
media-sound/easyeffects: require gcc to build 6.3.0
Enforced by upstream build scripts + code known to fail to compile against clang (see https://github.com/wwmm/easyeffects/pull/1739). Closes: https://bugs.gentoo.org/874342 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/easyeffects/easyeffects-6.3.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/media-sound/easyeffects/easyeffects-6.3.0.ebuild b/media-sound/easyeffects/easyeffects-6.3.0.ebuild
index 7df1501d43c1..b9f9b01ee3f3 100644
--- a/media-sound/easyeffects/easyeffects-6.3.0.ebuild
+++ b/media-sound/easyeffects/easyeffects-6.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit gnome2-utils flag-o-matic meson toolchain-funcs
+inherit gnome2-utils meson toolchain-funcs
DESCRIPTION="Limiter, auto volume and many other plugins for PipeWire applications"
HOMEPAGE="https://github.com/wwmm/easyeffects"
@@ -56,11 +56,10 @@ BDEPEND="dev-libs/appstream-glib
pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]] ; then
- if ! test-flag-CXX -std=c++20 ; then
- die "${PN} requires degree of C++20 support only available since GCC 10 or Clang 10"
+ if ! tc-is-gcc; then
+ die "Since version 6.3.0 ${PN} only supports GCC due to required level of C++20 support"
fi
-
- if tc-is-gcc && [[ $(gcc-major-version) -lt 11 ]] ; then
+ if [[ $(gcc-major-version) -lt 11 ]] ; then
die "Since version 6.2.5 ${PN} requires GCC 11 or newer to build (Bug #848072)"
fi
fi