summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 07:21:44 +0100
committerSam James <sam@gentoo.org>2022-07-26 07:22:06 +0100
commit876ecd41959cad8a382e2b364bf214c70ace77d5 (patch)
tree11ccc69ac7750079661a5c469edf774c5f7de76b /media-sound
parentprofiles: last-rite media-libs/libgroove (diff)
downloadgentoo-876ecd41959cad8a382e2b364bf214c70ace77d5.tar.gz
gentoo-876ecd41959cad8a382e2b364bf214c70ace77d5.tar.bz2
gentoo-876ecd41959cad8a382e2b364bf214c70ace77d5.zip
media-sound/spek: add 0.8.4
Makes ffmpeg 5 situation better but not yet enough. Bug: https://bugs.gentoo.org/834397 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spek/Manifest1
-rw-r--r--media-sound/spek/files/spek-0.8.4-disable-updates.patch11
-rw-r--r--media-sound/spek/spek-0.8.4.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/spek/Manifest b/media-sound/spek/Manifest
index 54f02a8e7449..60f47392b50a 100644
--- a/media-sound/spek/Manifest
+++ b/media-sound/spek/Manifest
@@ -1 +1,2 @@
DIST spek-0.8.3.tar.gz 1349573 BLAKE2B ce783c319741c43f27462caf9dcd27e71f4c8fbc9d3a3d2ac0b977189cca4cf8ed14f258958bbf59532c4cae97562fa20819222ae68567e9e607f243a2777000 SHA512 a4b54746316d295574bc963e650728b23b3730ee6bcc8d78b043a5678baac70a0e859870120de2b0e6a17059e9e3757075f4691e2abde98c083afc393e93e17c
+DIST spek-0.8.4.tar.xz 430096 BLAKE2B 4b3a512f0a8e74650161c9ed7ef0e054325d9f42743362180d970854fccc99cf20fcf329643ffbd0e84a5ee0aff746d2fc2750b91f300e29243ce1194b1b0d9d SHA512 08e39d4c0c7732feec159a8ff29550a62bab37a01325589787e027a027c50ee926f4cd9e0971061bf4e0b53a590b842c6586b4173e09cc9b27dd3b5668dc2d8b
diff --git a/media-sound/spek/files/spek-0.8.4-disable-updates.patch b/media-sound/spek/files/spek-0.8.4-disable-updates.patch
new file mode 100644
index 000000000000..8f498e7942e2
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.4-disable-updates.patch
@@ -0,0 +1,11 @@
+--- a/src/spek-preferences.cc
++++ b/src/spek-preferences.cc
+@@ -44,7 +44,7 @@ SpekPreferences::SpekPreferences() : locale(NULL)
+
+ bool SpekPreferences::get_check_update()
+ {
+- bool result = true;
++ bool result = false;
+ this->config->Read("/update/check", &result);
+ return result;
+ }
diff --git a/media-sound/spek/spek-0.8.4.ebuild b/media-sound/spek/spek-0.8.4.ebuild
new file mode 100644
index 000000000000..dbfa6ab4d593
--- /dev/null
+++ b/media-sound/spek/spek-0.8.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit wxwidgets xdg
+
+DESCRIPTION="Analyse your audio files by showing their spectrogram"
+HOMEPAGE="http://www.spek-project.org/"
+SRC_URI="https://github.com/alexkay/spek/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-video/ffmpeg:=
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.4-disable-updates.patch
+)
+
+src_configure() {
+ setup-wxwidgets unicode
+ default
+}