summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-11 12:57:45 +0000
committerSam James <sam@gentoo.org>2024-01-11 13:00:27 +0000
commit986e00639a6bd9ca0d650743941a1d7e6b903821 (patch)
tree3ff56831595bcdca663f4dfe10a97773f60a6438 /media-sound
parentmedia-fonts/sil-gentium: Stabilize 6.200 arm64, #921768 (diff)
downloadgentoo-986e00639a6bd9ca0d650743941a1d7e6b903821.tar.gz
gentoo-986e00639a6bd9ca0d650743941a1d7e6b903821.tar.bz2
gentoo-986e00639a6bd9ca0d650743941a1d7e6b903821.zip
media-sound/audacity: disable PCH harder
The build system handles its "config.h" header in an unusual way, where it passes -include via CMake as long as PCH is disabled. But it only checks its own build system option, not the standard CMake option to force off PCH, so we started getting build failures w/ the recent cmake.eclass change to pass the latter. Closes: https://bugs.gentoo.org/921731 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacity/audacity-3.3.3.ebuild4
-rw-r--r--media-sound/audacity/audacity-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/media-sound/audacity/audacity-3.3.3.ebuild b/media-sound/audacity/audacity-3.3.3.ebuild
index e242d4ca99ae..4e68dd30ca14 100644
--- a/media-sound/audacity/audacity-3.3.3.ebuild
+++ b/media-sound/audacity/audacity-3.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -166,7 +166,7 @@ src_configure() {
# Tell the CMake-based build system it's building a release.
-DAUDACITY_BUILD_LEVEL=2
-Daudacity_use_nyquist=local
- #-Daudacity_use_pch leaving it to the default behavior
+ -Daudacity_use_pch=OFF
-Daudacity_use_portmixer=$(usex portmixer system off)
-Daudacity_use_soxr=system
diff --git a/media-sound/audacity/audacity-9999.ebuild b/media-sound/audacity/audacity-9999.ebuild
index 82ce039fc3a4..ad59e3249ef7 100644
--- a/media-sound/audacity/audacity-9999.ebuild
+++ b/media-sound/audacity/audacity-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -151,7 +151,7 @@ src_configure() {
# Tell the CMake-based build system it's building a release.
-DAUDACITY_BUILD_LEVEL=2
-Daudacity_use_nyquist=local
- #-Daudacity_use_pch leaving it to the default behavior
+ -Daudacity_use_pch=OFF
-Daudacity_use_portmixer=$(usex portmixer system off)
-Daudacity_use_soxr=system