summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-02-05 20:56:57 -0700
committerTim Harder <radhermit@gentoo.org>2020-02-05 20:56:57 -0700
commita225a6d1138c13d7f70397059198a2128d17fd3e (patch)
tree9f729802406188cf510571ed8b615df115be2550 /media-sound
parentmedia-sound/abcmidi: remove old (diff)
downloadgentoo-a225a6d1138c13d7f70397059198a2128d17fd3e.tar.gz
gentoo-a225a6d1138c13d7f70397059198a2128d17fd3e.tar.bz2
gentoo-a225a6d1138c13d7f70397059198a2128d17fd3e.zip
media-sound/dir2ogg: version bump to 0.13
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/dir2ogg/Manifest1
-rw-r--r--media-sound/dir2ogg/dir2ogg-0.13.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/dir2ogg/Manifest b/media-sound/dir2ogg/Manifest
index d566bccf10ff..4a0c2fbc6e21 100644
--- a/media-sound/dir2ogg/Manifest
+++ b/media-sound/dir2ogg/Manifest
@@ -1 +1,2 @@
DIST dir2ogg-0.12.tar.gz 19608 BLAKE2B 39b1210b2458f7774aef64f29b07826a19b274d17a6038fc676557c8b15bed3662f851b87414b9318be154cdadd450001ea45bd8ed6103cffb2ee183511fe617 SHA512 bd76ba168b6e5305e4e5cfd87333200ec72a1d6e7055e966e1544abc842b39743b479b80c63382e10e85eebad92e97ec33e6fe52b0ace2df024ed50468e3946e
+DIST dir2ogg-0.13.tar.gz 20338 BLAKE2B 4f00c7e587eb7bba349d7024977d0d67ac9424a09649650e923df7100c60a67db78f363ac9d41931e969a5d8131f9461485f120cc4f308b0abcca4d5b570aba2 SHA512 292c35dd20a8e0499b3bd22d89c6ed0ae0abcf2b58f669316a2f39d45092a1c9a14fb168ad9ac893dfdd5138600c8be5e66502141c9dc7376b18e1e8d1ca5054
diff --git a/media-sound/dir2ogg/dir2ogg-0.13.ebuild b/media-sound/dir2ogg/dir2ogg-0.13.ebuild
new file mode 100644
index 000000000000..d0664c226995
--- /dev/null
+++ b/media-sound/dir2ogg/dir2ogg-0.13.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+MY_PR=$(ver_cut 1-2)
+DESCRIPTION="Converts mp3, m4a, wma, and wav files to Ogg Vorbis format"
+HOMEPAGE="https://jak-linux.org/projects/dir2ogg/"
+SRC_URI="https://jak-linux.org/projects/${PN}/${MY_PR}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="aac flac mac mp3 musepack wavpack wma"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=media-libs/mutagen-1.11[${PYTHON_USEDEP}]
+ media-sound/vorbis-tools[ogg123]
+ aac? ( || (
+ media-libs/faad2
+ media-video/mplayer ) )
+ flac? ( || (
+ media-libs/flac
+ media-video/mplayer ) )
+ mac? ( || (
+ media-sound/mac
+ media-video/mplayer ) )
+ mp3? ( || (
+ media-sound/mpg123
+ media-sound/lame
+ media-video/mplayer
+ media-sound/mpg321 ) )
+ musepack? ( || (
+ >=media-sound/musepack-tools-444
+ media-video/mplayer ) )
+ wavpack? ( || (
+ media-sound/wavpack
+ media-video/mplayer ) )
+ wma? ( media-video/mplayer )"
+
+src_install() {
+ python_doscript dir2ogg
+ doman dir2ogg.1
+ einstalldocs
+}