summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-10-02 21:14:57 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-10-02 21:14:57 -0500
commita767e91f33258655836c721c74c0b52223d7a3cb (patch)
tree220e53ea2d163f1fb9bc7b1ddb27528cdfe04c89 /media-sound
parentx11-drivers/nvidia-drivers: prepare for atk migration (diff)
downloadgentoo-a767e91f33258655836c721c74c0b52223d7a3cb.tar.gz
gentoo-a767e91f33258655836c721c74c0b52223d7a3cb.tar.bz2
gentoo-a767e91f33258655836c721c74c0b52223d7a3cb.zip
media-sound/spotify: drop 1.0.72-r1
Closes: https://bugs.gentoo.org/873868 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify/Manifest1
-rw-r--r--media-sound/spotify/spotify-1.0.72-r1.ebuild112
2 files changed, 0 insertions, 113 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index d446031b5067..59e00e83307f 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1 @@
-DIST spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb 95135550 BLAKE2B ad4587dd6b3c64a0398e0790203a7826e290a27542fa39ebbd6c7198d8ad1fd3fb06e8b030b64e1e61e0624ef20aafda08189266486cd073cb779ebff62ef502 SHA512 51d60f7592e5f31ea4b7e67736a85271cb48d4108459630da61c4ab67d2a470038240c1d6ff577280cb4498cf44f14d7bc7e0312f63d34265bcd1e70cd13142f
DIST spotify-client_1.1.84.716.gc5f8b819_amd64.deb 119770140 BLAKE2B 071ee877e9c6c9a64cc3e06cdd72530e5da60087c56c29ad9511ed427df987d76258142120442ad78370f2d78c282016025ed43f7f7e94b4efb44e4a201bc839 SHA512 3cc25f28ae791ac26607117a5df668f803ed8e58f0ace085010a6242fdde97766bdc1c752560850795c9b4324f3e019937fe9af2788a1946ebb70ee781f50d99
diff --git a/media-sound/spotify/spotify-1.0.72-r1.ebuild b/media-sound/spotify/spotify-1.0.72-r1.ebuild
deleted file mode 100644
index 5bc8a509cbd9..000000000000
--- a/media-sound/spotify/spotify-1.0.72-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils gnome2-utils pax-utils unpacker xdg-utils
-
-DESCRIPTION="Spotify is a social music platform"
-HOMEPAGE="https://www.spotify.com/download/linux/"
-SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
-#BUILD_ID_AMD64="117.g6bd7cc73-35"
-BUILD_ID_X86="117.g6bd7cc73-35"
-#SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb )
-# x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_X86}_i386.deb )"
-SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_X86}_i386.deb"
-LICENSE="Spotify"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="libnotify systray pax-kernel pulseaudio"
-RESTRICT="mirror strip"
-
-DEPEND=""
-# zenity needed for filepicker
-RDEPEND="
- ${DEPEND}
- dev-libs/nss
- gnome-base/gconf
- gnome-extra/zenity
- media-libs/alsa-lib
- media-libs/harfbuzz
- media-libs/fontconfig
- media-libs/mesa[X(+)]
- net-misc/curl[ssl,curl_ssl_openssl]
- net-print/cups[ssl]
- x11-libs/gtk+:2
- x11-libs/libXScrnSaver
- x11-libs/libXtst
- dev-python/pygobject:3
- dev-python/dbus-python
- libnotify? ( x11-libs/libnotify )
- pulseaudio? ( media-sound/pulseaudio )
- systray? ( gnome-extra/gnome-integration-spotify )"
- #sys-libs/glibc
-
-S=${WORKDIR}/
-
-QA_PREBUILT="opt/spotify/spotify-client/spotify"
-
-src_prepare() {
- # Fix desktop entry to launch spotify-dbus.py for systray integration
- if use systray ; then
- sed -i \
- -e 's/spotify \%U/spotify-dbus.py \%U/g' \
- usr/share/spotify/spotify.desktop || die "sed failed"
- fi
- default
-}
-
-src_install() {
- gunzip usr/share/doc/spotify-client/changelog.gz || die
- dodoc usr/share/doc/spotify-client/changelog
-
- SPOTIFY_PKG_HOME=usr/share/spotify
- insinto /usr/share/pixmaps
- doins ${SPOTIFY_PKG_HOME}/icons/*.png
-
- # install in /opt/spotify
- SPOTIFY_HOME=/opt/spotify/spotify-client
- insinto ${SPOTIFY_HOME}
- doins -r ${SPOTIFY_PKG_HOME}/*
- fperms +x ${SPOTIFY_HOME}/spotify
-
- dodir /usr/bin
- cat <<-EOF >"${D}"/usr/bin/spotify || die
- #! /bin/sh
- exec ${SPOTIFY_HOME}/spotify "\$@"
- EOF
- fperms +x /usr/bin/spotify
-
- local size
- for size in 16 22 24 32 48 64 128 256 512; do
- newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
- "spotify-client.png"
- done
- domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
- if use pax-kernel; then
- #create the headers, reset them to default, then paxmark -m them
- pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
- pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
- pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
- eqawarn "You have set USE=pax-kernel meaning that you intend to run"
- eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
- eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
- eqawarn "you suspect that ${PN} is being broken by this modification,"
- eqawarn "please open a bug."
- fi
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-
- ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
- ewarn "To remove the cache:"
- ewarn "rm -rf ~/.cache/spotify"
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}