summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-07 01:42:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-07 01:58:42 +0100
commitb0d943375d709508e5c4111cc3c2773995151505 (patch)
tree8bb82ffba5459271a0edafaa32273e25e224c6b9 /media-sound
parentmedia-gfx/xfig: remove unused patch (diff)
downloadgentoo-b0d943375d709508e5c4111cc3c2773995151505.tar.gz
gentoo-b0d943375d709508e5c4111cc3c2773995151505.tar.bz2
gentoo-b0d943375d709508e5c4111cc3c2773995151505.zip
media-sound/picard: 2.0.0_beta1 version bump
Bug: https://bugs.gentoo.org/644554 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/picard/Manifest1
-rw-r--r--media-sound/picard/picard-2.0.0_beta1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/picard/Manifest b/media-sound/picard/Manifest
index ecfb637d82f1..e0d5426b7455 100644
--- a/media-sound/picard/Manifest
+++ b/media-sound/picard/Manifest
@@ -1 +1,2 @@
DIST picard-1.4.2.tar.gz 2116021 BLAKE2B 9629d312df20a8c69b383b424724ef4cf9f774ae70b9e11b1c6c7f96cafea575657875642af70a73633ca79eb8c79237ada16dd5ff7c021d4bdb4a0df7890de3 SHA512 5e4a6a8cfadd86b7015ab77da1969acec26e0ed92564c6634afeee5060d33d34e8fc83015880e6c8f17df66c8d15b86a85031dbe5b596c995579fb449cf8a74e
+DIST picard-2.0.0_beta1.tar.gz 2661429 BLAKE2B ebffb2651e778c2cec8a4e41307d99c30038f36096b343489d7384b1cb4ac9a3492f23a4c69ec8a0be59306efc5cf4c9098a114445be6965ed243156dcee2803 SHA512 e2fc5dadf3e469df4ed16b1827909a60a54e7dc047e1ecd80480d9283a5795e3e792b31970eb6834590ba2ea12378ec18ef404b47237c38299350ee1d9acec9d
diff --git a/media-sound/picard/picard-2.0.0_beta1.ebuild b/media-sound/picard/picard-2.0.0_beta1.ebuild
new file mode 100644
index 000000000000..504aadd08a1e
--- /dev/null
+++ b/media-sound/picard/picard-2.0.0_beta1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+DISTUTILS_SINGLE_IMPL=1
+DISABLE_AUTOFORMATTING=true
+
+inherit distutils-r1 readme.gentoo-r1 xdg-utils
+
+DESCRIPTION="A cross-platform music tagger"
+HOMEPAGE="https://picard.musicbrainz.org"
+SRC_URI="https://github.com/metabrainz/${PN}/archive/${PV/_beta1/.dev4}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtgui:5[accessibility]
+ >=media-libs/mutagen-1.38"
+DEPEND="
+ nls? ( dev-qt/linguist-tools:5 )
+"
+
+RESTRICT="test" # doesn't work with ebuilds
+
+# upstream quickly renamed to dev4 after buildsystem and runtime(!) were broken by 'beta1'
+S="${WORKDIR}/${P/_beta1/.dev4}"
+
+python_compile() {
+ local build_args=(
+ --disable-autoupdate
+ )
+ if ! use nls; then
+ build_args+=( --disable-locales )
+ fi
+ distutils-r1_python_compile ${build_args[@]}
+}
+
+python_install() {
+ local install_args=(
+ --disable-autoupdate
+ --skip-build
+ )
+ if ! use nls; then
+ install_args+=( --disable-locales )
+ fi
+ distutils-r1_python_install ${install_args[@]}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
+calculation and lookup of AcoustID fingerprints.
+
+Install optional package dev-python/python-discid to enable
+calculation and lookup of compact disc identifiers (disc IDs).
+
+If you are upgrading Picard and it does not start, try removing
+Picard's settings:
+ rm ~/.config/MusicBrainz/Picard.conf"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}